GL-X300B-RS485

Hi I'm testing the RS485 port of the router and I'm able to read holding registers via the Web UI from a slave sensor, but when I use the libmodbus library with a custom package I get a CRC Error on the response and its always a leading 00. the response is: 00 01 03 02 02 8F F8 80 the first 00 shouldnt be there. I already tried this same setup and custom package with other routers (Teltonika) and different sensors but here I get that error so I'm thinking is a problem with the RS485 configuration but I'm unable to find the solution. any Insight on where could the problem be? or what exactly does the packages gl-sdk4-rs485 used in the webui does to stablish the connections as it is working over there. this is the final requirement needed to give a greenlight to a +1000 deployment based on this router model, any help is appreciated.
I suspect that maybe writing a custom modbust-set-rts function could help or changing the rts state or delay timeout

May I know the firmware version of the X300B?

1 Like

Hi the firmware is 4.15.16.

Have you tried any other sensors?
Can you take a few pictures and look at them?
Can you tell us what type of sensor you have?