Gl-x750 fw v3.211

We have an x750 running for several months, and it has worked perfectly. We’re using a virtual private server to host an OpenVPN server, and we are using the OpenVPN client in the x750. In the VPS, we have port forwarding rules configured to forward through OpenVPN. This has been working great. We are forwarding several UDP and TCP ports through to 2 raspberry pi units, including non-standard SSH ports.

We recently upgraded the x750 firmware to v3.211, and now the port forwarding is sporadic at best. SSH connects maybe 1 in 10 attempts. I did a factory reset on the x750, and manually reloaded the OpenVPN configuration and port forwarding. In the VPN section of the x750 admin screen, I can see that the VPN is connected.

Is there some new setting in the newer firmware that I missed? I’m sorry, I didn’t keep track of the firmware rev in the router prior to the upgrade, but we purchased the router a year or so ago if that helps. Do I need to upgrade the OpenVPN version on our VPS?


I don’t think there is any update about port forward.

Do you set up port forward from vpn to LAN?

In the vpn connection, there is one option - allow local access, have you enabled it?

Also, when do set up port forward, set up for both tcp and udp. I don’t know it matters but got report from one user that he need to set both.


I did try the Local Access option, that didn’t solve the problem.
I’ll try forwarding both TCP & UDP (we didn’t need to do that originally).

Yeah, port forwarding from the Virtual Private Server points to the IP address used by OpenVPN.

I may have found the problem…

I looked through Luci, and found System → Startup. In the list of services, ‘openvpn’ was set to Disabled. I have changed that to Enabled. I didn’t have to do that in the older firmware. I’ll let this run for a while, and do a few reboots and power cycles.

I don’t think you need to do that in the new firmware as well if openvpn is connected, as you saw from the default UI.

Seems there is something buggy.

I’ve been at this a while, trying to narrow down where the problem might be.
Have new ‘startup’ services been added in recent firmware?

I’m thinking about disabling some of those services, but I have no idea what many of these do. All I need is

  • OpenVPN
  • Networking
  • Firewall / Port Forwarding
  • Web UI
  • SSH
  • IPv4 (I already shut down IPv6)

Probably others I don’t know about.
Is there a way I can save the current config before I start changing these? Does the Backup tool in Luci save the startup app settings?


Some services are dependent on other services, so it is not recommended to disable them unless you are sure what they do. LuCI → System → Backup / Firmware does not back up the startup settings.

  • The services with “Start priority” < 99 are most likely to have other services dependent on them.
  • The services with “Start priority” = 99 are less likely to have other services dependent on them, but I would avoid disabling the services “lighttpd” or beginning with “gl_”.

alzhao thinks there is something buggy, so disabling services may not fix the problem anyway. It may be worth reinstalling the previous version that was working before.

I reverted back to v3.104, and that seems to have solved the problem.

I didn’t do a lot of testing, but it appears that the problems were happening with data coming from OpenVPN. I can’t tell if there was a lot of latency, or if packets were being lost.

Hope you can figure it out.

1 Like