GL-x750 won't up date

Ok to start off I had made a backup of original firmware, and that saved a zipped .tar.gz file.
Then I updated within the software on firmware update tab to “gl-x750- GO2020-03-01” rooter, with no problem. I was getting random disconnect and a reboot would always fix. Thinking a software update might address that issue.
Tried to update yesterday to openwrt-x750-3.203-0701.bin. it goes through the process but nothing changes, even my settings stays the same, and I have the box unchecked. So I got the bright idea to revert back to my back up, and then I can flash the updated 0701.bin.
Yes it reverted back to the old original firmware that came on the unit, with all the tabs on top. Ok let me update this to 0701.bin, nope not happening. Goes through all the motions, says it’s flashing, “Do not power off” the lights go on off, it reboots and nothing has changed.
I tried uboot so many times I’m sick, holding reset, plug power, wait 5 flashes, let up reset, we now have the power led and world globe led steady lit. Change IP address on PC local net work adapter, ipv4 properties save close. Go to address bar chrome or fire fox or
Can’t get into uboot on PC, tried rebooting, clear cache, in cognito mode. My wife is pissed and so am I.
Does anyone have any ideas? I don’t give up easily. Thanks for listening to my long story, please help.

I don’t know why you cannot go to uboot.

Can you check this video guide and pay attention to all the key points

If you have tried all steps but still cannot access uboot, maybe just change to another pc.

I will try another PC.
Thanks :pray:

Alzhao I tried another PC and i got into uboot.
Thank you :sunglasses:

1 Like