GL1300 wireguard crashing Router

I have a weird issue. I have my GL1300 connected to my router via Ethernet. Whenever I use wireguard and do a speed test or start doing anything that’s pushing the network it crashes my router (not the gl1300) but my home router I need to shut the power off and on again on the router to get internet back. What could cause that? I already tried resetting to factory defaults and also to install new firmware. No luck.

GLA1300? Which model is this? What is the firmware version?

Will it crash if you do speedtest without wireguard?

For whatever router crash when doing throughput test, pls check power adapter first. Usutally it is the reason.

What is the make/model of your home router?

I do not work for and I do not have formal association with GL.iNet

I’m using the Power cable that came with my Beryl Gl 1300 which one should I buy then ? It only happens with wireguard openvpn is ok but too slow for me

It’s the Fritzbox 6590

GL1300 Beryl. Firmware latest 4.3.7 I think

I mean change the power adapter of your Fritzbox.

But it’s the one that came with it. To which one should I change it? That doesn’t make sense

I think what @alzhao is trying to say is that we need to rule out an issue with the original power supply for the router. An easy way to do this is to test the router with a different power supply. My assumption of the issue that @alzhao thinks may be the issue is that running the speed test will stress the router requiring more power and if the power supply has an issue and is not able to supply the extra power the router crashes.

Yes. That is what I mean. Thanks for helping to explain.

This shouldnt be the issue because i ran it with the same router fine for months. It only started happening a week ago. i think after it updated to a new firmware because i remember the setup page looking different.

I have doubts that the problem is with the Fritzbox with the original power adapter, which is used by very many people. At the same time, I do not see how the Beryl router would cause it to crash.

Does the Fritzbox crash if you perform a speedtest when directly connected to it without going through the Beryl?

No it doesn’t . I want to say that not only does it crash when doing a speed test but also when watching a stream or something on Netflix

i want to update you guys that i tested it with a GL AX 1800 too. Same issue. Firmware version 4.2.3

and another update. It has to be something with Wireguard Implementation. Because with this new Router GL AX1800 i reach speeds with OpenVPN over 100Mbps that i was reaching with the Beryl on wireguard before. And it doesnt crash on Openvpn. So that means its not speed related. or CPU usage or something. It has to be an issue with wireguard either on this firmware or in combination with the firtzbox