GLi DDNS not updating in repeater mode

I just noticed that my individual DDNS address is still pointing to an IP I had while connected to a network this morning, but not the right IP I’ve got now. Could that be because I’m now browsing in repeater mode? I have internet access and my MT300A was rebooted several times, yet Gli-DDNS still points to the wrong address. Is that a know problem and if, can it be corrected? Can’t use resolved VPN connections as long as the DDNS is not correctly updated…

Thanks in advance!


Unfortunately when you enable vpn, the ddns will be pointed to the vpn server address. Is this the case of yours?

No, I use the Mt300a on the road to VPN into my network by setting up a VPN tunnel between the Mt300a in repeater mode (in hotel wlan etc. ) and a FritzBox (stationary ) . The Fritzbox accepts incoming VPN connections based on the Gli DDNS actual resolved IP to identify the Mt300a. Yesterday I noticed that my Gli DDNS gave an IP that came from a network I was connected to in the morning, yet I was already in a totally different Wlan of an hotel I stayed at for the night. I had full Internet access so that wasn’t the problem. But somehow the DDNS entry was not updated to the new IP and therefore my VPN connection was refused . . . Could the non updating DDNS entry be related to the Mt300a being in repeater mode (no wan used, Internet access via wlan-sta(?) interface?


Can we completely disable the DNS service? I went to advanced settings and don’t see a relevant package.

@AxeBro, yes of course. If you are using the newest firmware, you can disable “WAN access” in “access” page and ddns will be disabled as well.

@cvalentine, sorry for didn’t replying your questions. Have you solved it?