Goodcloud on MT-2500 Brume. "Device Timeout"

Hey all -

I just setup a Brume 2 and configured it at an off-site location.

It’s setup with GLDNS so I can remote access it via port 80/443 and I setup a wireguard server and I can connect to that.

I don’t particularly like having the web interface open to the public. However, I cannot access the device via “GoodCloud.”

When I login to Goodcloud, I can see the device and all but I see a “device timeout” message and when I try to access the web panel it takes me to https://127.0.0.1/?_=1708206215&devid=DEVICEIDHERE)

Obviously that URL doesn’t work. I’m not quite sure what to do.

In the brume logs for Good Cloud, it says “method not found.”

The device is behind an ISP router and ports 80, 443, and 51830 (or whatever wireguard is can’t remember) are forwarded to the device.

Any ideas?

You need to disable Force HTTPS on the router itself - it’s a bug, unfortunately.

Wow, that did it. thank you.

If Good Cloud is enabled, can I safely disable allowing remote “HTTPS Remote Access” ?

Yup, as long as you enable it in the GoodCloud settings page.

1 Like