Guest network IPv6

Hello GL-iNet forum,

I have the GL-MT1300 and have WireGuard working with IPv6.

I have enabled the Guest WiFi network and, when connected to the Guest WiFi network, can not access IPv6 (as per

When I am on the NON-Guest network, IPv4 + IPv6 work fine.
When I am on the Guest network, only IPv4 works.

What do I need to set or change so that the Guest network can have IPv6 access?


1 Like

Seems that the guest network does not support ipv6 now. I don’t have update.

1 Like

I see. Thank you for replying. Will you update this thread when the guest network does support IPv6?

I have an internal record of this request.


I have partially solved this with a simple firewall rule:

When i find the forward issues with the firewall, will update the post.

In the end had to edit /etc/config/firewall:

config rule
	option target 'ACCEPT'
	option name 'Allow-GuestWIFI-IPv6'
	option family 'ipv6'
	option proto 'icmp'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	list icmp_type 'echo-request'
	option src 'guestzone'
	option src_ip 'fe80::/10