Hotel captive portal strikes again

So I have had the opportunity to try my new MT3000 during a trip to Spain using an android tablet to connect (open network but with credentials needed in
captive portal to authenticate) . I have tried every single trick in the book (and I do mean every single thing that I have read about this problem on these fora over the years I have been hanging on here) to get the hotel’s captive portal to show up on my tablet to no avail. Connecting my tablet directly to the hotel’s WiFi, passing the captive portal and then cloning the tablet’s MAC to the MT3000 worked quite well but that was the only way.

Now the important question that I can find no answer to: I managed to get a cheap TL-WR802N travel router to try and using this in WISP mode, this small thing connected to the hotel’s WiFi immediately and got me to the captive portal straight away. Why was the TP-Link able to achieve what the GL.iNet couldn’t no matter what I have tried? What is the difference here especially with the GL.iNet being supposedly much more advanced and freatures-rich? Where is the weak link or the problem with the handling of captive portals on these routers that have caused so much grief to fellow travelers?

What’s the IP of the Beryl AX (192.168.8.1)?
What’s the IP of the TPlink( 192.168.0.1)
The subnet routing might not be allowed or used by another service at the hotel.

1 Like

Good shout but trying the Beryl IP on 192.168.0.1 still makes no difference in getting the captive portal to come up after connecting to the hotel’s WiFi. Also if the subnet routing is not allowed or occupied then wouldn’t you expect MAC cloning workaround to also not work?

So what size hotel maybe they have a small IP window for allocation.
Starts 192.168.1.10 to 192.168.1.80 (simple way of limiting connections) or something could also maybe forcing DNS request.
TP-link running some kind of Tomato OS?
DNSmasque issue?
Maybe the wifi encryption? or Bandwidth?
look at the settings of the TP-Link see whats different?

Lot of options
Any thing in the logs?

No, it is a massive hotel. Settings on both routers are exactly the same and TP-Link running original stock firmware. No difference with various DNS settings (automatic, manual, encrypted, forced…etc.) on the GL.iNet and the open WiFi connects with no problems at all and router gets IP but it cannot get the captive portal no matter what I have tried even when trying to point the browser to gateway IP of 172.10.0.1. No pointers on logs either.

Well well well, guess what! After pulling my hair off, it finally worked merely by connecting my tablet to the 2.4Ghz SSID of the GL.iNet and not the 5Ghz one. Now why this should make any difference is beyond me…

Weird
Little confused on what you did exactly?
You connected you tablet to hotel wifi 2.4Ghz entered info for captive portal, got a connection, then cloned MAC address to GL.iNet router, then connected to the router 2.4Ghz?

The TP-Link TL-WR802 could access 2.4Ghz and 5Ghz?

Legacy stuff maybe easy of use.

Casually inqure at the front desk. The answer might actually be first sign-in needs to be done on 2.4Ghz then once added can access 5Ghz because of the range difference. I mean who runs up and down hotel hallways chasing invisible creatures. Pokemon. Literally been told by someone when wifi mapping to optimize for this. But I digress the point is how the AP are set up 5Ghz prioritization.

The TP-link TL-WR802N travel router only does 2.4Ghz Right?

2 Likes

MAC cloning worked as expected regardless of the SSID band used. I then reverted to routers’s default MAC to try and get it to work without MAC cloning.

Hotel appears to only broadcast at 2.4Ghz (probably for better reach rather than speed) and so both my routers were only connecting to wireless 2.4Ghz on the WAN side. The problem is if my tablet was connected to the MT3000’s 5Ghz on the LAN side then I couldn’t not get the captive portal to show up and then I discovered that it would only work if the LAN connection was also established on the 2.4Ghz. As for the TL-WR802N however, that wasn’t an issue as it is a single band router anyway. Why would the band choice on the LAN side by itself make any difference to the router’s ability to pass through the captive portal page with all the other settings being exactly the same?

Maybe it gets bottle necked at the 2.4Ghz connection because the tablet on the 5Ghz connection is sending stuff way to fast and expecting to soon. Maybe 5Ghz timeout needs to be tweaked only thing I can think of.

1 Like