How do I REALLY reset the GL-AR750?!?!?!

I received my GL-AR750 yesterday, played with it, fell in love with it, then decided I was going to start from scratch and do a final clean setup…

I held the reset button in for 10+ seconds, but when it rebooted, it came up as my new SSID & and I noticed that MY new password and “goodlife” didn’t work…

I tried resetting it by holding the RESET button for 30,45 & 60 seconds. It still won’t reset to factory settings.
I tried the 30-30-30 routine… it still won’t reset to factory settings.

What’s going on here?!? How do you reset this thing?!?!

Thank you, Bobby


You should hold on greater than 8 seconds and less than 20 seconds to reset router.

1 Like

When you press down the reset button, you should observe the power button start to flash.

This has to be done when the firmware boot up.

PART of the problem was me using Brave browser (Great browser, but occasional issues…like this).

I just received my new GL-AR750S a couple days ago. I intended to use it as a travel router, but at this point, I’m beginning to wonder if I purchased the right product because, what should be a simple, straightforward process to perform a factory reset does not work.

I simply can’t understand why the Reset Button on the box fails to do a factory reset! I tried the 30-30-30 method several times with no luck. Then I tried holding the reset for 15 to 29 seconds several times. Nope!

I’m pretty upset. If I would have purchased some cheap Chinese junk router, it would be easier. But I didn’t buy some cheap ass router. I purchased a Premium router product and GL-iNET’s Flagship router! That’s disappointing.

Now, the GL-AR750S won’t even allow me in the box for administration!! And now, for whatever reason, I am also unable to connect to the router or admin the router?

I would appreciate some help. But, I’m extremely doubtful at this point because what could be more simple than pressing a Reset button? Simple or not, the button does not work.

I’m glad I kept the original box. Unfortunately, it appears hopeless and I’m gonna have to send the “Flagship” back to Amazon. It would be great if GL could provide a solution.


First, there is no 30-30-30 method. Never do that.

Don’t do it for 15 to 29 seconds. It is not correct.

The correct way:
After the router boot (the router have to boot up), simple hold down the reset button, the first led (power LED) will start to flash. It will flash once per second. 3 seconds later it will flash twice per second. 8 seconds later it will flash 4 times per second.

Now release your finger and wait the router to reboot.


Thank you very much for your quick response!

Evidently, it appears that the factory resets that I performed on my GL-AR750S-Ext was indeed reverting some of the computer’s settings, but it did not reset all. For example, I’m running 3.100, but regardless of how many times I did the factory reset, the 3.100 firmware was still there. Also, I noticed that on two resets, some of the network interfaces were not reset. These results were both surprising and confusing. Don’t know why, but I have to accept partial blame since you pointed out that I was not performing the reset correctly. I was frustrated.

When I realized that the resets were occurring (although the firmware never reverted), I carefully configured the company’s Flagship router from scratch. Not completely done, but the router is performing nominally (and I feel more confident about the product so far).

FYI, the reason I specifically purchased the GL-AR750S was to solve several challenging problems that we are experiencing at the laboratories where I work. But the primary motivation was to own the most secure and most powerful pocket router for traveling. I have been dealing with the Captive Portal issue that’s been widely reported. I will post some reports on this site later.

Regards, Tony Mars

yes, firmware…stands firm. the wording of ‘REVERT’ is confusing in gli-webadmin. it is used in the fashion of actually meaning “factory default of the current firmware” I guess it has never been addressed as a language issue since you just learned it and moved on.

1 Like

Thank you for making the definition of “revert” clear! My understanding was the firmware would somehow walk itself back to the release the router was shipped with.

Regards, Tony Mars

hey, I re-read this and it may have come off as me telling you to move on but what I actually meant was “me and everyone else” just moved on and that maybe I or we should have corrected this correct this.

1 Like

Hey rp201rp, I didn’t take it that way. I don’t mind being corrected regarding the issues I am experiencing with the GL-AR750S. This is the first router I have ever purchased that is open source. I know I’m gonna make mistakes. I was embarrassed, but that is a small price to pay for knowledge.

Privately, I’m laughing at myself for actually thinking that the firmware reverted back to the firmware installed on the router at the factory! So, I’m sure that when you read that, you cracked a smile at least. I’m fine with that, because as long as I’m learning new skills and fine-tuning my technical understanding, I’m in “hog heaven!”

@Tony_Mars How did you finally resolve this issue? I tried the suggestions in the comments here, but my GL-AR750 still says “Device login password” when I go to and the default password doesn’t work. Thanks.

I don’t know how you did but can you just reflash the firmware using uboot

1 Like

I had the same problem. I, finally, resolved it by unplugging my ethernet cable from GL-AR750.

  1. I held down the reset button until both 2G and 5G lights turned off and only the power button light was on. Then let go of the reset button.
  2. I made sure the device I was going to communicate to GL-AR750 was connected with wi-fi. I used the 5G one with goodlife as password.
  3. Typed in in the internet browser command line and then the language option popped up like it was supposed to.
1 Like

If it’s asking for a password then it hasn’t reset. A full reset should result in first being asked what language you like the interface in.

1 Like