How do I transfer files to the Hard drive I've connected to my Flint GL-AX1800?

I have a FLint GL-AX1800 with file sharing and OpenWrt DLNA Server running.
I can see the OpenWrt DLNA Server in my network connections on my PC.
However, when I click on it from my PC, all I get status page listing the files on the drive.
How can I physically transfer files to that drive from my pc? Is there a way to FTP into the drive?

I’ve tried logging into SCP but I keep getting access denied.
I’ve tried no credentials, I’ve tried my admin credentials…What do I need to use to log in?

dlna can be considered read-only.

you can use ftp, samba or better yet, sftp
ftp does not support hash checksum verification of file transfers, whereas sftp does.

1 Like

No credentials work to log in via FTP or SFTP
I’ve tried WinSPC and Filezilla.

It’s expecting credentials, but my admin credentials arent accepted. Nor is leaving them blank.
Are there instructions or anything for how to do this? Does the manual have nothing about how to transfer files to the router?

Something is missing here

need to use the same credentials as used for ssh.

for sftp server, might need to install it, very easy, no need to edit config files.
it just works…

opkg update
opkg install openssh-sftp-server
1 Like

Where would I type those commands in?
Where do I get the SSH credentials? I haven’t been promoted to create any anywhere.

It says there’s an integrated SCP server already in the pic below.
Damn, they need documentation for noobs like me.

the username should be root and the password is the same password used to login to the web interface.

and i thought that if you plug in an external drive into the usb port,
the router is automatically share the drive over smb.

file sharing is documented. basically, click install

1 Like

It is automatically shared, I just can’t FTP files into it.
I am unable to login in using root and the admin password.

install what? Where? I thought I had to FTP in?

over SMB/SAMBA, so it can be used by windows, apple, android, etc.

— did a quick forum search and found

— keep in mind, that glinet routers boot openwrt can access the web interface for openwrt, called LUCI.
and from there can install thousands of software packages.

1 Like

When I sftp to the router, Which folder is the one that corresponds to the hard drive attached to my router?

its under mnt

thanks all!

that is the root of the router’s linux filesystem.

note: your homedir is /root

So, root is the Linux router’s root, and mnt is the location where the hard drive that’s connected to the router within that root.

I’ve uploaded a bunch of media, but when i connect to the OpenWrt DLNA Server with my smartTV it doesn’t see any of it. Do I need to reboot the router or something to refresh the content?

sorry, confusing, two different roots, nothing to do with each other.

— the username root, which is the user you login as over ssh.
for user root, the homedir is /root

root@GL-AR750S:/# echo $HOME
root@GL-AR750S:/# cd ~
root@GL-AR750S:~# pwd

— the root of the router’s file system /
on windows, the equivalent is c:\

root@GL-AR750S:/# ls -al
drwxr-xr-x    1 root     root           608 Jul 13 16:11 .
drwxr-xr-x    1 root     root           608 Jul 13 16:11 ..
drwxr-xr-x    2 root     root           792 Apr  7 04:42 bin
drwxr-xr-x    5 root     root          1340 Jul 14 15:37 dev
drwxrwxr-x    1 root     root          2424 Jul 29  2021 etc
drwxr-xr-x    1 root     root           520 Jul 29  2021 lib
drwxr-xr-x    1 root     root           224 Jul 12 17:37 mnt
drwxr-xr-x    4 root     root           360 Apr  7 04:43 overlay
dr-xr-xr-x   83 root     root             0 Dec 31  1969 proc
drwxrwxr-x   16 root     root           235 Apr  7 04:42 rom
drwxr-xr-x    1 root     root           624 Jul 13 16:48 root
drwxr-xr-x    1 root     root           232 Jul 12 10:38 sbin
dr-xr-xr-x   13 root     root             0 Dec 31  1969 sys
drwxrwxrwt   23 root     root           700 Jul 14 17:20 tmp
drwxr-xr-x    1 root     root           480 Jul 29  2021 usr
lrwxrwxrwx    1 root     root             3 Apr  7 04:42 var -> tmp
drwxr-xr-x    1 root     root           232 Jul 29  2021 ww