How to have internet in Guest networks in WDS "slave" routers

Hello!
My config:
1xAR750S (192.168.8.1) WDS- AP on 5G.
2xAR750 (192.168.8.2 & .3) attached WDS-client on 5G. Everything is OK.
Guest network named “Guest” (192.168.9.1) on AR750S works OK with internet.
All devices get Internet on all the routers. All connected in the 2,4G network only. Working OK.

I want to make the same name “Guest” network on the 2 AR750 but I can’t having internet with this Guest network when devices are connected to the Guest’s AR750 network .

How to make it work?

Thx

802.11 doesn’t have the notion on VLANs. For a couple, one WDS link per SSID will do it. Any more than a couple and “beacon pollution” can become an issue. Firewalling between VLANs is needed at each router.

Edit: If you don’t need on-link connectivity between the segments, things are a lot easier as you can just route the traffic via your “master” router (assuming you’re using a star topology). The downside is that roaming from AP to AP won’t be “seamless” (need to get new DHCP, all connections drop) and things like mDNS don’t work across network segments.

Thx for the answer jeffsf !
But I still don’t know how to have internet in Guests Network in WDS-linked routers. I’m quite a beginner in OpenWRT…
I have configured Guest network in “master” router as WDS-AP and link as WDS-Client the Guests networks of the WDS-linked routers. Not working… because there is already a WDS-AP and WDS-Clients in same 5Ghz so maybe there is conflicts.
I think I miss something in the config…
Any idea to make it work?
Thx

It’s been a while since I’ve used WDS, but the sketch is as follows

  • Main Router

    • SSID: Private – AP
    • SSID: Guest – AP
    • SSID: Backhaul 1 – AP/WDS
    • SSID: Backhaul 2 – AP/WDS
    • Bridge: Private, Backhaul 1 (and perhaps your LAN)
    • Bridge: Guest, Backhaul 2
  • Secondary Router

    • SSID: Private – AP
    • SSID: Guest – AP
    • SSID: Backhaul 1 – STA/WDS
    • SSID: Backhaul 2 – STA/WDS
    • Bridge: Private, Backhaul 1 (and perhaps your LAN)
    • Bridge: Guest, Backhaul 2

If you run both 2.4 GHz and 5 GHz, then there would be one for each of Private and Guest on each router. The two 2.4 GHz channels on the two different routers can/should be different. All the 5 GHz radios end up being on the same channel, assuming you’re using 5 GHz for the backhaul.

1 Like

Thx jeffsf ! I will try as you said!
By the way you said " It’s been a while since I’ve used WDS…"
Can i ask you what you use now (in case you have multi-router network)? THX!

Since I’ve got more than a couple VLANs and four devices, WDS and a star topology doesn’t scale well.

I’m using batman-adv on 802.11s, though it has its own set of problems (primarily related to its “abuse” of ARP packets in a managed, heterogeneous network).
https://openwrt.org/docs/guide-user/network/wifi/mesh/batman

Thx!
I was in the good way but my error was to make all GUEST traffic on 5Ghz radio only with WDS only in 5Ghz. All my devices are connected to the 2,4Ghz so that’s why I didn’t have GUEST internet on them.
Bye

1 Like

I will try someday batman-adv but I think it’s quite difficult for me now, I’m a beginner in OpenWRT routers-
THX

Set the client to be WDS, but you set yourself your AP as you’d normally do, without WDS. Then you go in Luci and search the WWAN interface and check that it’s blocked like a WAN port, also make sure you don’t use the DNS of the router you’re guest in. You can do not that much wrong, just try. And yes obviously, WDS is for that purpose. I had never a problem to just remove the guest interface or anything I couldn’t explain myself, I would even suggest you try to do let have the clients also just regular client mode instead of WDS. Worked for me every time so far, plus, try if you can connect after you changed the mac address of your A750.

With the router my ISP set me up I do that with the AR750, it was no problem to set the 2,4ghz + the 5ghz one time as client in wds mode and the ohter two in access point mode without WDS.

If that’s for any reason isn’t working take a look at Dynapoint or similar opkgs, try setting up a shadowsocks for yourself etc. but it doesn’t seem to be worth the effort and the GL-UI is buggy when it comes to this, use LuCi to check your stats, so no worries, you get it working for sure.

wlan0 * SSID: GL-AR750 - Client (WDS) (I wouldn’t hide the SSIDs at all or not too soon, hidden SSIDs and WDS are no friends) setting up the connection, sometimes obviously that’s device specific.) or your mac addy gets blocked because of two many “failed” attempts**
*** wlan0-1: GL-AR7502g– AP (AP) (Which is buggy, you have to do that in Luci) **
*** wlan-1: GL-AR750-5g – AP
*** wlan-1-1: GL-AR750-5g - – Client - WDS (ONLY)**

**that does the trick.**

Also is is it not an option to let the WDS be WDS, use OLSR mesh or Dynapoint or inaydn, alred or batman? I think the first two are far easier to use and are a luci-app. Or better: Nothing you just don’t use WDS / Mesh. .since I never felt a real improvement in stability or anything, anyways. Besides that it is slightly faster when both are complete without encryption but hidden.

Thanks, surabi. Sorry i didn’t say anything about your help. Thank you very much!
Bye!