How to update Adguard?

Hi, just wondering if we could please get a guide on how to update Adguard on the axt1800? It used to be available from within Adguard itself and worked perfectly fine but that feature has been removed.
Thanks to anyone able to help since glinet doesn’t want to

The following commands are upgraded and record with SSH on the AX1800.
You will need to manually close AdGuard Home on the page before performing this.

curl -L -S -o '/tmp/AdGuardHome_linux_armv7.tar.gz' -s\
>     ''
cd /etc/AdGuardHome/
mkdir -p ~/my-agh-backup
cp -r ./config.yaml ./data ~/my-agh-backup/
tar -C /tmp/ -f /tmp/AdGuardHome_linux_armv7.tar.gz -x -v -z
cp /tmp/AdGuardHome/AdGuardHome /etc/AdGuardHome
root@GL-AX1800:~# curl -L -S -o '/tmp/AdGuardHome_linux_armv7.tar.gz' -s\
>     ''
root@GL-AX1800:~# cd /etc/AdGuardHome/
root@GL-AX1800:/etc/AdGuardHome# mkdir -p ~/my-agh-backup
root@GL-AX1800:/etc/AdGuardHome# cp -r ./config.yaml ./data ~/my-agh-backup/
root@GL-AX1800:/etc/AdGuardHome# tar -C /tmp/ -f /tmp/AdGuardHome_linux_armv7.tar.gz -x -v -z
root@GL-AX1800:/etc/AdGuardHome# cp /tmp/AdGuardHome/AdGuardHome /etc/AdGuardHome

Your configurations will be backed up to /root/my-agh-backup, so if something goes wrong you can download them and reset the firmware, then upload them to /etc/AdGuardHome
After successful installation, you can delete the installation package by executing the following command:

rm -rf /tmp/AdGuardHome
rm /tmp/AdGuardHome_linux_armv7.tar.gz



I’m having problems getting curl to work.

It gives the same message directly copying and pasting the commands provided

Ok I figured that out, but still have problems.

Please try placing the command on a full line to avoid the problems caused by line breaks.

curl -L -S -o '/tmp/AdGuardHome_linux_armv7.tar.gz' -s ''


wget -O '/tmp/AdGuardHome_linux_amd64.tar.gz' ''

This line of command downloads the installation file to /tmp/. You can also download it manually from GitHub and upload it to your device.

1 Like

Thank you, placing it all on a single line fixed it.