How to upgrade Adguard on the Flint, auto and manual?

AdGuard Home is now at 107.7 and I’ve tried to upgrade to it and get the same error as genki was getting. I’m on 3.214. I tried the manual upgrade AdGuard recommended, but got an error in AdGuardHome executable when I tried to run it. I fell back to 107.6 as I made a backup before I started.
Will I have to wait for 3.215 to be able to upgrade AdGuard to 107.7?

I am on AX1800 firmware 4.0 and I can just upgrade to 107.7 and it is fine.

I assume it should work on 3.214 as well.

Did you upgrade before? Maybe just reset firmware and try again.

Firmware 4.0 upgrade the agh is failed for auto update?

Sorry for the late reply. I am not sure what you mean by ‘reset firmware.’ I have rebooted the router twice and checked for new firmware. I have not upgraded to 4.0, and probably won’t until it is in general release. I did upgrade to 3.214, but that was when I first purchased the router last month. I am somewhat familiar with the UX as I upgraded to the Flint router from the Slate travel router (which rocks).

How to clean the old files? only 13m free space left after update ADH

Here’s how I manually update AdGuard Home on Flint by using WinSCP (SCP protocol):

  1. Get the latest version on this link: Release AdGuard Home v0.107.17 · AdguardTeam/AdGuardHome · GitHub
    (For Flint, it’s going to be the AdGuardHome_linux_armv7.tar.gz)

  2. Download this file and extract it somewhere you prefer. You should have this folder extracted:

  3. Open WinSCP and connect to the router’s IP: (default, make sure to change this if you change the LAN IP) and put in root as the username and your password. Make sure to select SCP as the File Protocol

  4. Head to the folder /etc and you should see AdGuardHome there:

  5. You’re gonna want to copy these folders as these are your backups for restoring your AG settings: agh-backup and data folders (paste it somewhere you prefer like, desktop)

  6. Log into Flint’s router page and stop AdGuard Home process.

  7. Now, copy the extracted file earlier downloaded from AdGuard’s Github to the router’s etc folder using WinSCP, you may drag the folder from your desktop going to the etc folder. and overwrite it.

  8. Once done, copy and paste the 2 folders that were copied earlier (agh-backup and data) and paste it in etc/AdguardHome/ then overwrite it.

  9. Head to AdGuard Home’s settings page and re-enable the AdGuard Home process then click on the Settings Page:

  10. Check the version on the bottom to see if it has been updated:


Great and awesome! I did it. How about Beryl? Same file as well?

Not sure about Beryl as I don’t have it with me. Based on this thread, it would be AdGuardHome_linux_mipsle_softfloat.tar.gz

I try to used same as the flint file but it’s not working the adguard home?

The file is different for Beryl. I posted a thread on my previous reply. You can try this file for Beryl: AdGuardHome_linux_mipsle_softfloat.tar.gz

Okay, noted with thanks.

Yes, great and awesome! I did it for my Beryl. Thanks so much for your kindness help.

1 Like

I finally got the upgrade to work! I had run an upgrade a month earlier and it was still sitting in the backup folder. It seems that the AdGuard upgrade process would not overwrite the files in the backup folder, /etc/AdGuardHome/agh-backup. I was also running out of space to even add another .ovpn connection. I sshed in and manually deleted the AdGuardHome executable in the backup folder, and the upgrade worked just fine (I was also able to add another .ovpn connection) . The upgrade process also copies the old files to the backup folder, so once I’m satisfied the new version of AdGuardHome is working fine, I’ll delete the executable in the backup folder.


Yep just tried this deleting the agh-backup files, and it worked.

Thanks AllenJ

Successfully updated Flint, but for E750 Mudi I don’t know which file to download. The …linux_armv7.tar doesn’t work

I have AGH installed on my Spitz, but I don’t recall if the QCA9531 CPU (same as Mudi) used 32-bit mips or mips LE for the AGH install to /opts. For the mips_24kc, I’d try the 32-bit mips first (uname -m shows mips).

These commands from SSH work on a variety of platforms too to figure out the architecture.

opkg print-architecture

ubus call system board

uname -m

Thanks, it is mips_24kc and 32-bit mips worked.

The last time I used the following method and it worked: Auto upgrade

Is there an updated process for this? I did this on my new Flint 2 and everything broke. The adgaurd server would not start.

1 Like

Perhaps you used wrong architecture for Flint 2. You should use

1 Like