How to upgrade the tailscale on MT-3000

Have anyone had upgraded the tailscale to 1.36.2?

Thank you.

1 Like

The tailscale can be upgraded only with the firmware. Later firmware updates will be updated to the latest tailscale.


Not sure if this helps or is allowed but I figured out a way to get the tailscale package upgraded without needing a firmware upgrade. Steps are a bit involved but worked on my GL-AX1800 (Flint). My device is arm based but the tailscale arm package was just too big to put on the GL-AX1800. After a bit of testing I figured out I could use upx to compress the tailscale and tailscaled packages from the arm downloads ( and move them over to the router. Once I replaced the files I was able to start the tailscale service from the GUI. Tailscale machine pages shows my system updated now as well.

Can you tell me more details? Is using arm64 or arm which version?
Is using the default (no parmater) on upx compress?
Have any problem after upgrade ?

Just wanted to note that I was able to successfully do this, as well.

Download the ARM64 versions of the static binaries from Tailscale. Then you should install upx on your system (on a Mac like me you can install via Homebrew). Compress using upx --best which should cut the size of the binaries roughly in half, the tailscale binary ended up being slightly larger than the prior version and tailscaled was smaller (for 1.44.0 vs 1.32-dev-t).

After you’ve done that, just scp the two files over to your MT-3000 using the admin password (ssh is root@ w/ your admin password) and replace the files found in /usr/sbin/tailscale and /usr/sbin/tailscaled with the correct files. Afterwards, disable and re-enable Tailscale on the GL-Inet config webpage. It should work and you’ll see it connected in your Tailscale machine list with the correct version.

Works flawlessly for me.


Thank you for your reply.
I have not mac. When I using Windows to compressed them (tailscale& tailscaled), report file already packaged.
When I using Linux to compressed them, the windows (put te packaged files from linux to windows) report virus.
The following is my packaged files information
9284 tailscale.arm64 filesize
15048 tailscaled.arm64 filesize
2003c3064eb7b1197a18025bc56a9bb2 tailscale.arm64 md5check
17f4da84a85990380f719176d7a740af tailscaled.arm64 md5check
Is it same of yours??

No, it sounds like your antivirus software is messing with the files. I don’t know what to tell you about doing this on Windows. Best guess is you could set up WSL2 and do it there, but the MT-3000 runs Linux, so you should have some passing familiarity of Linux if you’re going off the beaten path like we are here.

I’ve been able to successfully update to 1.48.2 after the 4.4.5 firmware upgrade using this method, just today, so this method still works correctly.

1 Like

Anyone have similar instructions for Beryl AX? /usr/bin/tailscale doesn’t exist on it

This will update Tailscale to 1.52.1 as per another post.

cd /tmp; curl -f -L -o tailscale_1.52.1_arm64.tgz
tar -zxvf tailscale_1.52.1_arm64.tgz
mv tailscale_1.52.1_arm64/tailscale* /usr/sbin/
1 Like

I performed these steps on my GL-AXT1800 with 1.54.0 for ARM (ARM32 not 64) and it “works”… kinda. Upon reboot the device DNS services utterly fail. I have to reboot the device with Tailscale disabled then enable it after boot to work correctly. Has anyone else hit this issue or is it just me?

I did the same procedure to update to 1.56.1. But i can not get custom exit node to work…
Also i can not ping devices withing tailscale network when connected to igl router. When i use tailscale directly on the machine it all works. Any help, could it be that this version 1.56.1 of tailscale doesnt work with mt-3000? I can see mt-3000 in tailscale admin console and tailscale status on router shows rather okay responses.

Will there be a firmware update soon? Mine is saying there’s a security vulnerability on the version that is installed (version 1.32.2-dev-t) in the current firmware.

1 Like

Please try this:


This blog describes step by step settings.

The step that is not listed (that makes the program actually works is that you need to set file permissions).

They need to be RXWR-XR-X or 0755

You can change this settings in WinSCP.

1 Like

Or just use the script above.

1 Like

Yep. The script worked well for me via SSH

Of course you can use the WinSCP solution if you’re not comfortable with SSH; just make sure the original read/write permissions are preserved.


Well, I was talking about that script:

But glad it worked.

Okey dokey


[EDIT] uname -m returns aarch64 on the Beryl AX (MT-3000)