Huawei 3G UMG1691

How to setup properly Huawei 3G Modem on GL-iNet? I tried to use both GL-iNet interface and Luci, but none of them work.

Can you see /dev/ttyUSB* or /dev/modem etc?

yes, I can see /dev/ttyUSB0, /dev/ttyUSB1, /dev/ttyUSB2. I don’t know why it is assigned to all those 3 devs, but only ttyUSB2 can communicate to the modem. The problem is, after it gets connected to /dev/ttyUSB2, it get timed out and hung up. So, the next time it tries to reconnect again, it says NO CARRIER.

ttyUSB2 should be the correct port. It maybe you input wrong parameters. Can you check your apn, dialnumber, even username, password or pin.

I am still struggling with this. I can assure you that apn, dialnumber, username and password are all correct. I did test on TP-Link the same 3G modem with all of those parameters and it worked just fine. What else could be the issue? I also did factory reset, erasing all earlier setup, but it still does not work.

There is a post of this modem and have the same problem. But the author didn’t post a solution.