IMEI change


I have Mudi. is it possible to change imei to increase anonymity on the LTE network?

1 Like

Search the forum and the first record.


Mudi with modem version EP06ELAR03A07M4G. Software ver: 3.105.

I try to repair IMEI but i have error message.

I go to Internet/AT Command/ and in AT Command i make "AT +EGMR=1,7,“123456789101213” "

What am I doing wrong ?

Best regards, sunseeker

Can you make sure the double quota is correct.

it worked.

The strange thing is when i did ctr + c, ctr + v from the previous post: it showed an error. Only when I manually rewritten the command was performed correctly.

Thank you for your help.

As Alfie wrote, it was probably the quotes ". There are different ones that look very similar, but don’t work. For example this " and this ” look similar, but don’t act the same. You need the regular " quotes.

I’ve had to remove the comma before the quote sometimes. Doesn’t seem to be any rhyme or reason on the specific format needed to make it work.

In his case the command is like this, without spaces and just quotes on the end:


And yes depending on the modem some accept without the comma or without quotes, but the command spec should be as above if they follow it correctly. Notice the kind of quotes also, some sites use other quotes and copy paste won’t work.


I am having same issue trying to change imei. Internet>at command>shortcut=manual command at command I enter what is shown and port = /dev/ttyusb2. I get an error and does not change imei. Any suggestions

You tried without last comma and/or without quotes? Also be sure to try eliminating the space between comma and imei number. Basically try different combinations with/without comma and quotes.

Hi just wanted to ask… If you change the IMEI does the isp see the changed imei? How can I confirm this?

Is there a certain imei your suppose to input so it dosent look spoofed?

The ISP sees the changed IMEI.

Only can confirm if your SIM does needs a specific IMEI to work.

for some imeis command works, imei gets changed, new imei is displayed in webui but my isp still sees old original imei

How do you know that the ISP sees the old imei?

after you login to isp account you may see some isps display device name model based on imei but to make sure i simply called them and asked

Can you tell me which ISP have that info?

I didn’t have this myself. It may be good to check.

let me correct myself. it might be bug on isp side.
for example for polish i login to account and see they recognize my device model.
then i change imei, imei change with at command always works.
i then relogin to account and mostly i see isp recognizes new device based on new imei.
for some imeis though isp still displays old device, hence i said they see old imei but this could be also bug, perhaps imei is invalid or they did not find device in their database for that specific imei.

Yes, that may be the case. Thanks for sharing.