Inconsistency between GL-iNet GUI and LuCi 17.01.4 for WiFi speed

Hi, I’m running the latest Firmware 2.27 on my AR150 router. I noticed bad WiFi performance last time and found out (using LuCi) that the WiFi radio was configured to “Legacy” (i.e. 802.11bg) while it should be “N” (i.e. 802.11bgn). I corrected the setting and WiFi is fine again, however the GL-iNet GUI is still showing the WiFi Mode as 11g (54M). This is inconsistent.
Furthermore, as the radio was set to “N” before the update to the LEDE build, the update must have scratched the correct setting.

Can someone from the development reproduce this issue and address it in a future release?

The WIFI mode of AR150 is 150M by default. Could you please have a try to set it on GL.iNet GUI?

Hi kyson-lok,
thank you for your suggestion. The 150M mode is not recommended a.f.a.i.k. because it is using a channel width of 40MHz which can lead to higher interference with neighbour networks. Furthermore I read somewhere that Apple devices aren’t even supporting the 40MHz channel width within the 2.4 GHz band. Please correct me if I’m wrong.

I did some further research: If you select the wifi mode 72M (11ng) in the GL.iNet GUI, an entry in /etc/config/wireless with the option hwmode = ‘11ng’ is written to that config file. However when you use the “Advanced settings” (i.e. LuCI) and adjust the wireless settings from here, the option hwmode is set to ‘11g’. According to openwrt wireless the option ‘11ng’ is not valid, rather the option htmode = ‘NOHT’ shall be used to disable the 11n mode (for details see also here) or left away to enable the 11n mode.

I think this is where the inconsistency comes from.

1 Like

Thanks for this. Seems this is the problem. Not sure when this settings was introduced. But will test and try.