Independent subnets for each LAN port (Flint 2)

Is there an way to have independent subnets for each Flint2 LAN port?

The idea is:

• Wireless network will be provided by Flint 2 (GL-MT6000), running ADGuard, which is connected directly to the modem.

• Brume2 (MT-2500A) running VPN Client will be connected to Flint2 LAN Port 3, providing connection to SmartTV, where Brume2 will be its own DHCP Server.

• Beryl AX (GL-MT3000) running another VPN Client will be connected to Flint2 Port 4 and the purpose of this device is to provide the Wi-Fi only for IoT, where Beryl AX will be its own DHCP server.

Is there an way to have these 3 devices working in a totally independent network, not talking to each other?

There totally is, but you will need to educate yourself about all the necessary topics.
https://openwrt.org/docs/guide-user/start#network_configuration

So, yep, there is a way.
Is it an easy one? Nope.

I just connected Brume2 and Beryl to my ISP Router, setting different Static Subnet IP on each one and looks like it’s working :thinking:

But doesn’t looks the correct way and I have no idea how my ISP Router is handling the route between the clients from different subnets going to internet.

You can login via luci via advanced settings, from there:

  1. click on network tab → interfaces

  2. click on the tab devices and edit br-lan

  3. There you see bridged devices, deselect the port device you want for the second network.

click on save, now click back on the tab interfaces and create a new network interface.

fill in the fields like so:
protocol: static
device: this is your port device
ip address: 192.168.33.1 (also you can do different classes aswell check rfc1918 on wikipedia via google)
subnetmask: 255.255.255.0 this takes the full 255 range
Gateway: leave empty

click on advanced settings, uncheck default gateway, go to dhcp create dhcp settings, click on the firewall zone and assign it to a new one.

now you only have to edit the firewall zone via network → firewall, set input to accept, and forward it to zone wan.

1 Like

Thanks for the step by step, @xize11 :+1:

I’ll try it tomorrow!!

1 Like

Hi, what do you mean with “deselect the port device”?
There is a device list but there is no way to deselect it:

Ah, you need to go back, there is a tab devices, edit br-lan.

Absolutly fantastic!
Everything is working as I need.
Thanks, @xize11

1 Like