Inseego M2000 (OpenVPN Client) connecting to Brume 2 (OpenVPN Server)

I’m able to use several Gl-inet devices as clients to my OpenVPN Server with no issues, except one.

Inseego M2000 (OpenVPN Client) connecting to Brume 2 (OpenVPN Server) - I get “invalid config file”.

Anyone familiar with what file format and settings M2000 expects?

Here’s the VPN Client side log:
VPN Log
Sat May 27 22:54:38 2023 OpenVPN 2.4.3 arm-oe-linux-gnueabi [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Dec 5 2022
Sat May 27 22:54:38 2023 library versions: OpenSSL 1.1.1b 26 Feb 2019, LZO 2.08
Sat May 27 22:54:38 2023 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Sat May 27 22:54:38 2023 Outgoing Control Channel Authentication: Using 256 bit message hash ‘SHA256’ for HMAC authentication
Sat May 27 22:54:38 2023 Incoming Control Channel Authentication: Using 256 bit message hash ‘SHA256’ for HMAC authentication
Sat May 27 22:54:39 2023 TCP/UDP: Preserving recently used remote address: [AF_INET]:1194
Sat May 27 22:54:39 2023 Socket Buffers: R=[163840->163840] S=[163840->163840]
Sat May 27 22:54:39 2023 UDP link local: (not bound)
Sat May 27 22:54:39 2023 UDP link remote: [AF_INET]:1194
Sat May 27 22:55:39 2023 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Sat May 27 22:55:39 2023 TLS Error: TLS handshake failed
Sat May 27 22:55:39 2023 SIGUSR1[soft,tls-error] received, process restarting
Sat May 27 22:55:39 2023 Restart pause, 5 second(s)
Sat May 27 22:55:44 2023 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Sat May 27 22:55:44 2023 TCP/UDP: Preserving recently used remote address: [AF_INET6]2607::1194
Sat May 27 22:55:44 2023 Socket Buffers: R=[163840->163840] S=[163840->163840]
Sat May 27 22:55:44 2023 UDP link local: (not bound)
Sat May 27 22:55:44 2023 UDP link remote: [AF_INET6]2607::1194
Sat May 27 22:55:44 2023 write UDP: Network is unreachable (code=101)
Sat May 27 22:55:44 2023 Network unreachable, restarting
Sat May 27 22:55:44 2023 SIGUSR1[soft,network-unreachable] received, process restarting
Sat May 27 22:55:44 2023 Restart pause, 5 second(s)
Sat May 27 22:55:49 2023 All connections have been connect-retry-max (1) times unsuccessful, exiting
Sat May 27 22:55:49 2023 Exiting due to fatal error

It appears that the username password configuration is not recognized correctly

I figured it out with help from Chat GPT. GL-Inet OpenVPN config has 2 lines which Inseego doesn’t like. once I commented out “nice” and “mute” it was good to go and my inseego is connecting with GL-Inet router (Brume 2). Thanks. Lastly, Inseego also needs compatible cipher (AES-128-CBC works).

auth SHA256
cipher AES-128-CBC
#nice 0
#mute 5
verb 3

I’m good to go.

2 Likes