Installing Stock Chaos Calmer on GL-MT300N

Hello all,

I absloutely love the GL-MT300N router!! However I would rather install stock openWRT firmware on the device. The GL-Inet software has some neat features, but there are many I wont use. I would rather do a vanilla install and then add all the features from both as needed. I purchased the device for a business trip I’m taking and wanted to have this connect to pfSense back home with openVPN.

Security is more important to me over ease of use. I have tried installing some packages to increase security on the GLI image, (LUCI SSL) and was not able to get it to work. I am also not interested in the remote management feature on the base image…

Unfortunately for all of us the openWRT site has been up and down over the last few days so it makes research more difficult. I have found some other openWRT repos I can use for sourcing file to build an image for MT-300N.

If it were you, how would you go about creating a stock openWRT image for this router? Or is there already one that exists? There are multiple builds listed on that repo, are any/all of them compatible? I noticed they all show mt7620 but don’t differentiate between the n or the a version. I’m guessing that it doesn’t matter.

I am fine with compiling the image, just have never done that before… If i find a decent guide i should be fine… I have Linux CLI experience. If i’m successful I would be more than happy on sharing the image so it could be put on the downloads page. It looks like this was done for the ar-150…?

Thank you so much for the wonderful hardware!! :slight_smile:

Well, if you have no problem with compiling yourself: Here you go (debian system)

first install all depencies

apt-get install zip libxml-parser-perl build-essential libncurses5-dev m4 flex git git-core zlib1g-dev unzip subversion gawk htop python libssl-dev quilt screen file

Then you need to clone the CC Repository with the needed patches:

git clone GitHub - domino-team/openwrt-cc: openwrt CC with Domino/GL patches

cd openwrt-cc

./scripts/feeds update -a

./scripts/feeds install -a

make menuconfig

then select the packages you want to include and as target: Ralink RT28xx / RT3xxxx

Subtarget: MT7620

After you´ve selected all the packages you want to include save the settings and type in make -j4

after some while you will see the compiled image in the bin directory.

Easy as that :slight_smile:


FWIW, I run an AR-150 with the the GLI GUi and OpenVPN.

If you just installed Luci-SSL (luci-app-openvpn??) then OpenVPN might not work. You also need openvpn-openssl though I expect it would be installed as a dependency.

The GLI GUI is a big benefit when working with a mobile device for connecting to APs (STAtions), but in any event is so much easier than using LuCi to change STAtions. It also virtually eliminates the issues related to forgetting to uncheck the create additional networks, which is a killer on the road (with out an Ethernet cable)

You probably want to disable the DDNS feature. It’s posted elsewhere on the forum here.

I am trying to do the same thing. Compiling a stock Chaos Calmer for MT-300N / MT-300A.

What puzzles me here is that the Domino Team openwrt-cc seems to have patches for both mt300n and mt300a but they don’t show up in menuconfig.

I see the target profiles under Atheros for Domino Pi and GL-AR150 and GL-AR300.

Where are the profiles for MT300N/A?

I understand from @Rene that we can just select Ralink MT7620 and all should be fine, but why then have these profile patches?

I must be missing something…



For MT300N/A, first choose “Ralink RT288x/RT3xxx” from Target System, then choose “MT7620 based boards” from Subtarget, then you will find the profile in Target Profile

Does anyone know if Image Builder supports this device? There is nothing on the openwrt page yet and only hints by searching the forums and the Internet. I’ve been given a few hints in the forums but am not doing this stuff as a hobby so not always sure what they mean.

I know how to use IB however, just need to know which version supports it that hopefully isn’t trunk as that is all I can find at this moment.


UPDATE: 404 Page not found - GL.iNet