iPhone 7 tethering issue with GL-AR750S-EXT

Thanks very much for the suggesstion, it almost solved my issue! :slight_smile:
So first of all I went from the latest OpenWRT firmware back to the latest official firmware that is 3.211at the moment.
Then I turned on IPv6 support and changed it to NAT6. By default this was not working for me, but I noticed that my mac got an IPv6 address as well. So I went ahead, installed Luci and checked out the details. On the interfaces panel I saw that there was a wan6 interface now, that was an alias to the regular wan. But instead of having an address, it said that the device is not present. So I started guessing and edited the wan6 interface, and changed the device from @wan to eth1. After only this change everything started working. It got an IPv6 address and the computer also had internet connectivity.
Interesting thing is that on the regular admin page it didn’t see the internet connection (the tethering icon is gray as the others), but that wouldn’t concern me (and I think this is only because I messed with the default configuration). However after a reboot everything was back to the original settings with the @wan device instead of eth1.
Now I know my use case is special, because I don’t use the regular wan port, only the USB tethering interface, but I would be really glad if you could incorporate a fix somehow for this in the next release.
My exact usage is this:
At home I have a USG-3P as a main router with a wired ISP. Now that sometimes fail, so I need to tether my phone into the wan2 port of the USG, and I would like to achieve that by having the AR750S plugged in constantly but with its power turned off. So when my ISP fails then I just turn on the AR750, hook up my phone to it and I have internet everywhere again. Now this is almost possible except that I need to enter the GUI and change the device after the bootup. (and sometimes I’m not home, only my wife… :slight_smile: )

So I hope you can help me out on that somehow :slight_smile:
Oh, also Native mode for IPv6 is straight up not working in my case, my computer doesn’t get an IPv6 address for some reason, not even after doing the @wan->eth1 switch.

Thanks again for your help!

native teljesen kuka

eth1 interface is the iPhone interface. Can you confirm that you made it work manually?

Have you tried to tethering your phone to your computer? Does your computer get IPV6 as well?

How about sharing phone as a hotspot via wifi? Is it IPV6?

Hi,

yes I can confirm, that with the manual changes mentioned above, it was al working fine.
Tethering via USB os via WiFi to my computer I got an IPv6 address both time.
I tried one more thing: I tried the repeater function of the router to connect to my phone’s WiFi hotspot with the IPv6 option enabled, but everything was the same. Then I opened Luci, found a new interface called WWAN that was set to use DHCP. Switched it to DHCPv6 and now everything works just fine via WiFi hotspot option. (But the main screen still doesn’t show internet connectivity) Unfortunately, this also gets reset to a regular DHCP after a reboot, so this is pretty much the same as with the USB tethering option.

1 Like

Hi there,

so I was wondering if you could tell me: will there be a fix for this issue? No rush or anything, I’m just wondering if I should wait for an official firmware update or update the router to a standard OpenWRT installation, and maybe check back on the official firmwares from time to time.

Thanks,
Zoltan

Yes there will be a fix for tethering via ipv6. Fortunately we do have ipv6 on phone and be able to set up the dev environment.

That sounds great, then I’ll just wait for your upgrade. Let me know if you need any help testing.

Cheers