iPhone + GL-MT300N-V2 Issue

I have a GL-MT300N-V2 that USB tethers correctly with an Android device. However, if I try to use an iPhone SE the router identifies the connection as “eth1” vs. USB which doesn’t connect (obviously) has any ran into this issue and able to resolve it?


Quick update:

I think I was able to resolve this. I had to go into the advanced menu on my Mango and set the bridge on eth1 to include the USB interface. I tried the tether again on my iPhone SE (ios14.4) and it connected.

Several things about iPhone tethering:

  1. If you are using IOS 14 you have to use firmware 3.105 and later. Just try to upgrade to the latest version of iOS and router firmware (now 3.201 snapshot)

  2. Your phone, when connected to the router, will pop up a message asking to trust this computer. Click trust. Then enable hotspot. Click connect of the eth1 on the router.

  3. You should get IP address. If not, turn off the hotspot on your phone for 5 seconds then turn it on again. The router should have connected.

  4. If still cannot connected, try reboot your phone and router. Then do the above again.

  5. If still does not work. Give up. Buy new phone or router.

Glad that this helps. But should not be the reason.