iPhone tethering doesn't work on MT300N-v2

I uploaded my Mango Mini Router (MT300N-v2) to the latest firmware (3.105) that was supposed to solve tethering issues with iOS 14, but it doesn’t seem to work.

I’m currently running iOS 14.5 and when I connect via USB my iPhone to the router, the blue tethering icon on the top left screen of my phone shows up (as it was sharing datas) but I cannot connect my iPhone in tethering mode through website interface.

Tried to turn on and off hotspot and tethering mode multiple times, factory reset my router, plug in and out my phone, set up DSN, nothing seems to work.

I’m just wondering why it doesn’t connect in tethering mode even though the blue icon on my iPhone appears. Any help?

I had this exact problem with an iPhone 8 and iOS 14.4. I tried everything you did with no luck.

Interestingly, my 10.5" iPad Pro (also running iOS 14.4) worked just fine.

Guess what? Rebooting the iPhone solved the problem! It works fine now.


this is really strange. But thanks providing another way to try.

1 Like