iPhone unable to connect to Beryl wifi

GL-MT1300 Beryl with 3.215 firmware.

iPhone 13 mini (iOS 16.2) is unable to connect to Beryl’s wifi (2.4g and 5g both), but can connect to other wifi, and other devices (android phone & tablet) can connect to Beryl.

iPhone’s screen shows Beryl’s SSID and trying to connect, but it won’t show it connected. Sometimes show a message about cannot connect.

I tried to reset iPhone’s wifi settings and disable/enable wifi.
Is there a compatibility issue on Beryl with iPhone’s wifi?

Thanks.

I didn’t have any report about iPhone connectivity.

I only have report that windows has problems connecting to WPA3 wifi if you changed wifi key.

Anyway can you try to forget the SSID on your iphone and check again?

Also can you try change encryption to wpa2?

I tried to delete SSID config already but didn’t work.

However, iPhone can connect after changed to wpa2, although other devices are working fine with original settings.

Thanks for your help. And I hope we can use wpa3 with iPhone later.

I have the same issue. Since iOS 16, iPhones cannot connect to Wifi anymore, if not set to WPA2. Fix, please?

IOS 16.2? I am on 16.1 and hesitate to upgrade.

All of them. Since 16.0 and it’s still not working with the latest update.

I have the pretty same issue with iPhone 13 mini and iOS16.2.
The interesting thing is, that the iPhone is able to connect to 2.4g Wifi but not to 5G Wifi (GL-AX1800 Flint). Both are configured with WPA3-SAE.

My iPad Pro with iPadOS 16.2 connects without any issues to both. My MacBook with macOS Ventura connects also without any issues. Both devices have older hardware than the iPhone 13 mini.

Update:
I have done some testing. When WiFi-Mode is set to n/ac/ax then it is working with WPA3-SAE.

I can confirm that IOS 16.x has a problem with Beryl WPA3.

Beryl 4.x firmware should be OK.

That’s great. But I will wait when 4.2 becomes stable release.