iPhoneX USB Tethering Advice

Thanks for your summary. @andyh747 Could you please have a try with @kyphos 's advice?

Have tried multiple ways to connect via USB and three different cables. No difference.

Can connect perfectly with wifi tethering but not USB.

Update on my findings.

After multiple attempts I finally got USB tethering to work but it was a mystery as to what worked in the end. Thanks go to @kyphos above with the sequence for connection. Although I had tried this previously, strangely it seemed to work this morning after several attempts.

So it finally works on both USB and wifi tethering.

Thanks to everyone for responding and helping.

Glad my ‘recipe’ helped, though I’ve found it’s not 100% solid. Usually works, but not every time.

Yes it can be a bit flaky but overall I’ve got it working ok.

Now I’m thinking of switching across to a 3G/4G USB dongle for internet through the AR150. Can anyone recommend a USB dongle which works well and they’ve tested? I’m on Three mobile provider here in the UK and have looked at the list of compatible dongles but wanted to check if anyone has a recommendation for one with good reception?

In case this can help resolve the issue, I’ve also been unable to tether my iPhone XR running iOS 12.2 either thru USB or wifi. It will show connected but will not pass internet to the LAN. I’ve installed v3.022 and tried multiple cables, using the above sequence, but it still refuses to work.

Then I connected a cellular iPad Pro running 12.1.3 via USB and it connected instantly and started passing internet to the LAN. Could the iOS version be a factor?

There is one day I cannot tethering my iPhone X for no reason. But the next day when I test again everything is fine.

Maybe you can reboot your iPhone?

Interesting. A reboot didn’t change anything, but setting custom DNS servers in the GL.iNet console seemed to help, both iPad and iPhone are tethering now.

I should have mentioned, this is on the MT300N-V2 Mango router.