Iptables GL-iNet

Hi all,

I need help to configure the custom-rules on the GL Inet.

During active openvpn connection I can’t connect to the NAS on the other local network of the fritzbox router, when I switch off openvpn all is working.

Of course all other communication shut run over openvpn!.

Picture of network structure

Nas has the IP adress

Please help to configured :grinning:


thanks for the input and help but no success :roll_eyes:

I did this like recommended

but was not working, if I disable VPN ping is OK

With OpenVPN not working.

Please help further! also Netflix and so on. must be opened without VPN.


Can nobody help??? Technical support please help!.

Can you execute the following command on the GL router and tell me the result?

ip route show table 52

Attached the table !

Check whether the IP you set is in the bypass table of ipset first

ipset list gl_bypass_vpn_domain

And then you can check the routing path on the GL router using the following command

ip route get from iif br-lan mark 0x80000


attached the picture.

No help !!!, please support

Any news, any help ???

I deleted previous post as I overread some information, which made my post senseless.

Nevertheless, as you have written that Netflix and other also should not use the VPN would it be an option to rather specify what should use VPN instead of what should not?


that is maybe correct but the goal shut be first to get this work so…
So please somebody can help what to do!

I agreed. First it should work, therefore I would first try the other way around, because if that also is not working, it may be easier to rule out other options.

You could try adding this to your openVPN client config

route net_gateway

I’m very sorry that I didn’t notice your message. If you want to call me, you can directly @me.
You can try adding the following firewall rules

iptables -I FORWARD  -d -j ACCEPT