IPv6 issues on B1300

Hi all,

I use a B1300 behind a FritzBox 7530 with PPPoE passthrough enabled. I have native IPv6 provided by my ISP, with a 2a02:8011:xxxx:xxxx::/64 Neighbour Discovery prefix, and a 2a02:8010:xxxx::/48 Prefix Delegation.

After enabling IPv6, I have been able to ping ipv6.google.com from the router, and it has a 2a02:8011:xxxx:xxxx::1 address in the GUI; although, nothing appears for the DNS address (ISP provided an address for this). It took about 30 minutes for my devices to be assigned IPv6 IPs.

Now the problem is that they have been provided with IPs from 2a02:8011:xxxx:xxxx::/64 rather than 2a02:8010:xxxx::/48. It appears they aren’t functioning as I am unable to ping ipv6.google.com, and ipv6-test.com doesn’t show IPv6 as in use.

Should I change anything in /etc/config/network or /etc/config/glipv6? Any help would be much appreciated!

Can you share your current ipv6 configuration? I need some screenshots.

Asterisks * used in places for privacy
 
etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5d:de31:70e1::/48'

config interface 'lan'
	option ifname 'eth1'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option hostname 'GL-B1300-4bc-5G'
	option ipaddr '192.168.8.1'
	option igmp_snooping '0'
	option ieee1905managed '1'
	option ip6assign '64'
	option ip6hint '0000'
	option ip6ifaceid '::1'

config interface 'wan'
	option ifname 'eth0'
	option hostname 'GL-B1300-4bc-5G'
	option metric '10'
	option proto 'pppoe'
	option username '***'
	option password '***'
	option disabled '0'
	option peerdns '1'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname '@wan'
	option disabled '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 1 2 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'

config interface 'guest'
	option ifname 'guest'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.9.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

 
etc/config/glivp6

config globals 'globals'
	option origin_ula_prefix 'fd5d:de31:70e1::/48'
	option enabled '1'

config interface 'wan'
	option interface 'wan'
	option addrmode 'auto'
	option dnsmode 'auto'

config interface 'lan'
	option dnsmode 'auto'
	option lan_ip6addr 'fd5d:de31:70e1::1/64'
	option mode 'relay'

 
etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option nonwildcard '1'
	option localservice '1'
	option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option force '1'
	option ra_management '1'
	option dhcpv6 'relay'
	option ra 'relay'
	option ndp 'relay'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'guest'
	option interface 'guest'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option dhcpv6 'disabled'
	option ra 'disabled'

config domain 'localhost'
	option name 'console.gl-inet.com'
	option ip '192.168.8.1'

config dhcp 'wan6'
	option interface 'wan'
	option dhcpv6 'relay'
	option ra 'relay'
	option ndp 'relay'
	option master '1'

 
root@GL-B1300:~# ifstatus wan6

{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 1124,
        "l3_device": "pppoe-wan",
        "proto": "dhcpv6",
        "device": "pppoe-wan",
        "metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2a02:8011:****:****::1",
                        "mask": 64,
                        "preferred": 172389,
                        "valid": 258789
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2a02:8010:****::",
                        "mask": 48,
                        "preferred": 171610,
                        "valid": 258010,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2a02:8010:****::",
                                        "mask": 64
                                },
                                "guest": {
                                        "address": "2a02:8010:****:10::",
                                        "mask": 60
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2a02:8011:****:****::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 258789,
                        "source": "::\/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::4afd:8eff:feaa:a4d1",
                        "metric": 512,
                        "valid": 1389,
                        "source": "2a02:8010:****::\/48"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::4afd:8eff:feaa:a4d1",
                        "metric": 512,
                        "valid": 1389,
                        "source": "2a02:8011:****:****::1\/64"
                }
        ],
        "dns-server": [
                "2a02:8010:1::212:23:3:100"
        ],
        "dns-search": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ]
        },
        "data": {
                "passthru": "001700102a028010000100000212002300030100"
        }
}

Also, as mentioned previously, it took about 30 – 45 minutes for an IPv6 address to be assigned to devices when I first enabled IPv6. Since then, if I disconnect from the network and then reconnect, the IPv6 address shows up in ipconfig immediately; however, it still takes about 30 – 45 minutes for IPv6 to be recognized as in use when testing on ipv6-test.com, and for pings to IPv6 addresses (such as ipv6.google.com) to not time out.

ipconfig example output from a device:

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : lan
   IPv6 Address. . . . . . . . . . . : 2a02:8011:****:****:54:76:53ea:3534
   Temporary IPv6 Address. . . . . . : 2a02:8011:****:****:31ab:9f66:ddd8:ff3d
   Link-local IPv6 Address . . . . . : fe80::54:76:53ea:3534%10
   IPv4 Address. . . . . . . . . . . : 192.168.8.164
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : fe80::9683:c4ff:fe09:4bd%10
                                       192.168.8.1

 
Additionally, I emailed my ISP (Zen) and they responded with the following:

You are right in that it is the intended behavior for LAN devices to be given an address from the PD prefix. However, as they are initiating PPPoE, they will be assigned a WAN IP from the ND prefix instead.

I don’t imagine this will cause you any issues but as it’s a none standard configuration, I can’t be sure.

 
Finally, it appears that the DNS server is now showing in router’s GUI, for what that’s worth.

Thank you in advance, it’s much appreciated!!

2 Likes

@luochongjun would you be able to help with the configuration details I’ve provided? Thanks in advance.

1 Like

sorry for reply late.
I think all the confusion now may be Neighbour Discovery (ND), which will automatically find the available route when the IPV6 network fails, which explains why it takes you 30 minutes to assign an IPV6 address.

We can disable upstream router Neighbour Discovery and check the link connection of IPV6 network first

1 Like

I see. Thank you for the help and explanation. Would that be something I can configure myself, or is it something that will have to be added via an update?

This can be configured on your upstream router.