Issue MT1300/AR750S in AP mode connected to mesh network

Im a very happy user of my Beryl MT1300 or slate AR750S . Both are settings as access points mode (as a mini mobile extension network) to a main wifi device (connected to my main network). That setup is working very well.
Now in some cases i need to get more surface coverage without drops. So decided to put my main wifi router as a master of a mesh network (wifi6). The network is working great and for example i dont have any issues using smarphone that can switch from a mesh node to another (smarphones can be connected in wifi6 or wifi5 protocol). However my Beryl Or Slate (in AP mode) doesnt seems to switch at all between the differents nodes.
Still I can connect my Glinet to the main WIFI router to the declared mesh SSID as before but when I move to another mesh coverage, my Glinet cannot reconnect automatically. It is like the SSID doesnt broadcast thue the differents mesh nodes.
I observe that if i try to configure any of my Glinet as an AP mode device from a location that is only cover by one of the mesh node (except the master of course), i cannot even see the global mesh SSID.
Is someone can help ?
thanks !

This seems strange. At least you should be able to see the SSID.

The router does not roam as your phone. Smartphone can roam between different mesh node using 802.11r etc. But routers does not work like this.

Have you checked WPA3? I am not sure if this is the case, have you tried change your wifi to WPA2?

I alzahao, thanks for your answer. I will try to be more specific :

I tryed differents configurations. 1st to make sure I setup my mesh network again to be sure that i didnt made a mistake on the configuration. My mesh setup is based on 2x Xiaomi AX3600, (wifi 6 with official mesh support with the last firmware). Then I setup my 2 Glinet router in WDS mode link to the ax3600 using the SSID. the security level is WPA2 only to avoid any problemes, both Glinet firmware are up to date.
When I setup the WDS mode within the range of the master router, both Glinet are working well but unfortunatly they doesnt automatically switch to the mesh router and when i move around and they both just lost connection. If I setup the Glinet near by the mesh router, It happen exactly the inverse and none on the glinet are connecting to the master router when i’m around.

To make sure I did the same using an android phone and an ipad and both are switching correctly when i move way and way back.

  • Maybe the Glinet router connection links are based on the MAC adress more than on the SSID?
  • Maybe it exist a plug in who can manage this ?

I think you are right. When setting up as WDS (wifi bridge) the router is just locked to BSSID so it will not roam.

When you use as WISP repeater, it should be able to roam.

I too can confirm the bug mentioned above. The bug being that if the mt1300 when placed into repeater or extender mode and if you are connected to a mesh network with multiple satellites and a main router that the config in the beryl only tries to connect to the original BSSID (MAC address) that it was connected to when you configured the beryl to be a repeater or extender. the beryl does not just look for the SSID name, which is the same across all units. Took me hours of trying different things but I definitely figured out what it is doing as it is repeatable in this behavior every time. it was very frustrating at first

This bug needs fixed so that people with mesh networks can actually use the product in these configurations. Currently the repeater or extender features will not function with mesh networks unless you can always connect to the same satellite or main router which defeats the purpose of having a mesh network and trying to use this product.