Issue VPN Policy Routing Wireguard with AR750S IP Leak

Hi GL.Inet community,

have following issue with my newly bought AR750S:

I try since hours get my mullvad connection over wireguard to work without any succes, cause if I’m testing with it tell me that my IP Address is exposed.

Before I bought this tiny nice Slate i had a TP-Link Archer C7 v2 with Openwrt 18.06 on it for my routing and vpn purposes. Everything worked fine on my old router. But now with configure everything like on old router the wireguard connection with mullvad doesn’t work correct.
I’m using the package VPN-Policy-Routing to route some of my network clients to wireguard interface and some to the wan interface.

So first I show you my Openwrt Firewall interface config:

The only difference what i’ve found between old config and new config is this custom firewall rule that I can’t delete. Maybe this is the problem?

Or all my problems related to this bug in v3? → GL.iNet - Connecting The World To Secure Wi-Fi

Maybe anybody can guide me to solve this. Also tried to post more than one picture, but yes I’am new to your community and can only upload one! Sorry for being a noob…:wink:

Never tried VPN policy routing. Maybe it caused by mwan3, you can try to stop it.

If you use the admin web page, does it work correctly? btw, we are developing VPN policy routing now.

1 Like

Thank you for your answer. Will try it! Wireguard VPN is working from normal GUI. So the GL.Inet community is developing their own VPN Policy Routing thingy beside this project → ? Sounds interesting? Any betas to test?

It is still at developing stage. It will be available soon, but not yet now.