Issue with Tor and Switch


I’ve got a MT300A, I’ve just installed the TOR firmware and I’m having a couple of issues. The switch on the side seems to have no impact, in either the left or right position I can access the UI and login (I’ve tried closing my browser, clearing history, rebooting the router etc). The Tor connection status shows connected in either position. I was running 2.25 before I changed the firmware.

Having read the docs I should only be able to view the UI with the switch is to the right and TOR should not be connected. Is this correct?


I’m having the same exact problem

Did you reserve setting when switch to Tor firmware?

You should not reserve any settings.

I didn’t reserve setting when I switched to Tor firmware.

I actually held the RESET button for 10 seconds out of frustration, and now all 3 LED’s are full and I can’t even connect to

Then can you use Tor?

All LEDs is up means tor is on.

When I go to it say’s I’m not using Tor.

Also the switch functions as its supposed to now

I can’t figure out how to get back to the page where i could place the vpn config

You changed to tor firmware then there is no vpn page.

You need to flash the original firmware back.

Check GL.iNet download center to download the firmware

I never fixed this. When I used it said I wasn’t connected and my question above was never answered. Since I don’t really use Tor it wasn’t really an issue but would have nice to have fixed it.

I tried flashing the original firmware 4 times.

But when I press the upgrade button after selecting the proper .bin it simply doesn’t do anything.

Also when I try resetting the router it just reverts back to the Tor firmware.

Any advice?

can you just use uboot web failsafe: Overview - GL.iNet Docs

I don’t know what is happening in your side. I just tried once more using multiple MT300A devices.

I downloaded v2.264 tor firmware from GL.iNet download center

Flashed to the original firmware without reserving settings. After reboot, the Tor firmware works exactly as expected.

I’m having the same issue, except mine is on the v2 model… Tor says it’s connected but nothing is being routed via tor. I connect directly to my modem and Tor doesn’t work… Not to mention the wireless scan when trying to connect the wan to an ssid, doesn’t work. Manually entering an ssid also doesn’t work…

But, Tor is broken in this firmware. Switch on the left or right… UI says tor is connected, but nothing goes out via TOR. Frustrating…

I’ve seriously been having nothing but problems ever since I flashed to Tor.

So I was finally able to boot web failsafe and just like everything else I’ve tried - it didn’t do what it was supposed to.

I followed the instructions exactly (kinda hard to mess up, and I watched the video on youtube) and tried several times and with both the WAN and LAN ports.

When I tried the uboot fail safe, the 3rd LED (the one on the far right when you’re facing the front of the router) blinked RED exactly 4 times, and then the second LED went full green. The first LED was full green the entire time.

notes I have a yellow, GL-MT300N-V2. After initially receiving the router, I “upgraded” the firmware through the UI to the current version. At this point I should have entered my information for my VPN, but I didn’t (I thought I’d come back to it later because I hadn’t bought the VPN service yet). Then I flashed to the Tor firmware and I couldn’t get the check tor page to say I was using Tor. After watching a video on youtube, it seems that there is some sort of open connection that I (along with probably most of the other ppl having problems), need to disable. At that point Tor should work.

However, I’m trying to get both Tor and and a VPN to work.

Any advice?

1 Like

This is my exact problem as well. I have the same box as you. When I connect the wan via physical cable I can see the TOR status is connected, but nothing gets routed out tor. It doesn’t matter if I am using the wifi or ethernet. Like you said, it seems like there’s a route that needs to either be disabled or a route that needs to be configured to get Tor to work. Not sure how this is so difficult. It’s supposed to work out of the box. Anyway, i’m looking at a few sites that deal with lede and Tor specifically, and looking at their shh commands/configs. It may take me a few days but if I figure anything out, I’ll report back.

Devs should really look into this. Right now Tor firmware for MT300N-V2 is broken and doesn’t work at all. Also, documentation if poor at best. I understand and appreciate the effort… But I think things are getting lost in translation perhaps.

Jesterking- are you able to reset your router? Have you tried the boot web failsafe? Neither of these resets works with my router.

I will not stop working on this until it’s working correctly. Period.

I have the blue router coming tomorrow as well, but I was planning on playing around with DD-WRT on that one,

Please keep us updated.

I have bricked a few times and uboot worked fine for me… Connect via lan and Ethernet cable, static up your computer

Web browse to . It should work…

hey so I was able to uboot and then uploaded lede-mt-300n-v2-2.27.bin.

I can connect to the GL-MT300N-V2-ce4 wireless network and everything’s still cool with only the first LED solid green.

But as soon as I go to the 3rd LED starts blinking red.

I can WISP my home network as well, but the 3rd LED’s always blinking red.


the led color is red, so it flashes when you have data in wifi.

yeah the third LED is your wireless interface. So if it’s blinking red that means there’s data transmission. The first LED is power, and the second is nothing (if I recall correctly). If you use the TOR firmware, the second LED is the TOR connection status.

Otherwise, you can program that LED to be whatever you want… I haven’t played with it yet to figure out how to do that…