Issues running Openwrt custom image

Hello!
I’m trying to compile custom Openwrt image for gl-mt300n-v2.
My Configuration:
Target System (MediaTek Ralink MIPS)
Subtarget (MT76x8 based board)
Target Profile (GL-Inet GL-MT300N-V2)

The compilation is sucessful, after flashing it to router and after attempt to access to 192.168.1.1 i get only one file downloaded with content:
#!/usr/bin/lua require “luci.cacheloader” require “luci.sgi.cgi” luci.dispatcher.indexcache = “/tmp/luci-indexcache” luci.sgi.cgi.run()

What am i doing wrong?
I’m trying to compile clear firmware with some changes in kernel. What packages and drivers should i include in menuconfig? Thanks in advance.

Nothing additional. Try default first. Obviously you tried to include LuCi without success, which is NOT included by default.

oopps, sorry, i didn’t mentioned that i did include Luci in my build.
My configuration is:
Luci → Collections → <>luci
Luci → Modules → <
>luci-base
Luci → Modules → <>luci-mod-admin-full
Luci → Modules → <
>luci-mod-rpc
Luci → Modules → Translation → <*> Russian

Could you try this repo? GitHub - gl-inet/openwrt: This repository is fork from openwrt official repo, we will update the latest tag and release GL.iNet firmware based on it.

As I never include LuCi in official openwrt custom build, I can not help here. But you might ask in the openwrt forum. As you might have run into a bug.
My custom build official openwrt for the 300N-v2 works well without LuCi.

Thanks everybody for suggestions. The problem is solved. I just excluded package lighthttpd. So just need to uncheck Network → Webservers → <>lighthttpd