Issues with PPPoE on Flint 2 (GL-MT6000)

did you ever get this to work?

i am having the same issue - newest firmware FW 4.5.6.

I can connect if i turn ipv6 on, but i’m worried about the data leakage via vpn (wireguard) + ipv6

My last router (ASUS r66u) worked fine with no ipv6 turned on. Can someone please help.

I couldnt fix. Even with IPV6 on, it wouldnt work for me. I just flashed latest OpenWRT Snapshot into my router, and it all works now.

Could you please flash the latest firmware? GL.iNet download center

version4.5.7 ,on the date of 2024-03-11

@austinmrs Could you try it too?

looks like this firmware is still in beta - do you know when it will be released as stable? or should i do it anyway. let me know! and thx for the quick response.

Please do it anyway but do a backup of your configuration before. It will need a few more weeks (or months) before this firmware will be marked stable.

What is your Vlan ID?

Yeah, We are in testing. Till now it looks good. This firware will release as stable in this week.

2 Likes

Will try later, For now im using OpenWRT snapshot and im happy with.

Does this latest firmware you have fix any of the wifi issues reported on this router?

This firmware based on MTK closed source wifi driver. The wifi is better than open source wifi driver version. And people also have Positive feedback on it.

Does it also fix the PPPoE issues? With the original firmware I cant connect to the internet using PPPoE. It just doesnt work. Even turning on IPV6, it doesnt work.

With openwrt it works immediately

Will this stable version be released this week? Could you let us know if everything is ok? if anything is really going to come out this week.

Yes. Will release today.

You can try it. We fixed one PPPoE issue. But not sure is same with yours.

Hi.
On my Flint 2 randomly loses connection to the network.
When I change Flint 2 to TP-Link, the connection works properly.
My internet is FTTH with ONT terminal.
Firmware: v4.5.7
Where is the problem ?

Logs https://pastebin.com/uuYPP43e

1 Like