Just bought Convexa-B (GL-B1300), 5G WiFi not visible

Hi, I just bought the GL-B1300. It’s a great router with awesome features, but one thing is frustrating me. I can’t seem to find and connect to the 5G WiFi.

I’ve checked many times in the Admin Panel that it’s turned ON and visibility to SHOWN. The 2.4G WiFi and the 2.4G Guest Wifi is visible, but not the 5G WiFi.

I checked on my Lenovo Windows laptop, and Samsung S10e phone. Both can’t seem to find the 5G WiFi.

This happens on the latest stable firmware 3.027. I’ve also tried to upgrade to 3.104, but it’s still happening.

Any help would be appreciated, thank you.

Can you check the band 5G wifi is using? Change it to another value and check.

One more thing, did you ever change country in the 2.4G or 5G wifi? Pls do not change country. When you change country of 2.4G, 5G wifi also get affected.

If you mess up the config, do a “revert firmware” and clean everything it should be fine.

If the above does not work, pls ssh to the router and get log using

iw list

It’s currently set at automatic 20/40/80 MHz

I wasn’t even aware of country settings in the Admin Panel ^^;
Do you mean the Time Zone? I did change that one because it says that the time differs from browser, so I synced it. Should I turn that back to UTC?

I might just try this right now.

Not this, I mean channel 49, 60, etc.

Timezone is not country. Country can be modified in advanced settings. I modified once and 5G is dead. After revert it is working fine.

I just did Revert Firmware. 5G WiFi is now visible!

I tried to connect to the 5G WiFi, but it says that I can’t

I haven’t really tried the Advanced Settings, let me try to access it and see.

Strange, can you ssh to the router and get logs?

iw list

I played around in Advanced Settings, and I noticed that the Country Code defaults to US.

I changed it to my country code and it seems like it solves the problem. I’ll monitor it for the rest of the day.

Thank you so much for the help, @alzhao.

If this works, next I’ll have to learn how to setup encrypted dns using NextDNS and stubby haha.

It will be difficult. NextDNS should be used on 1907. We added to Brume beta firmware.


Ah ok, I assume you mean I should use OpenWRT version 19.07. And currently GL-B1300 is still on 15.05…? I didn’t notice. That’s seems to be pretty old.

That is very cool. Will it come to GL-B1300? And will I be able to use my own NextDNS configuration?

Or is there another recommended way I can use NextDNS with GL-B1300 for the time being?

Thanks again.

You can flash a vanilla firmware from openwrt 1907 and use on B1300.

If I do this, I assume I’d lose the GL.inet admin panel? Can I roll back to the GL.inet firmware if I find issues?

Edit: If I use vanilla OpenWrt, can I still setup mesh router using the button on the router? Thanks.

Sorry for many questions, This is my first time using GL.inet product and also my first time using OpenWRT.

I managed to use NextDNS, by replacing the Cloudflare’s address_data and tls_auth_name with NextDNS’ on the /etc/stubby/stubby.yml file.

So far so good. Pretty happy with the setup for now. Now I might have to purchase a second router for mesh networking :smiley:

1 Like

Hi, sorry for asking you again. I was thinking about installing OpenWRT 19.07, but then I found this post:

The post is from last year. Is this still the case? Thank you.