LAN remote access via WireGuard connection

I have WireGuard VPN Server running on my GL-MT300N-V2 (Mango) router at home.
I now abroad and use WireGuard VPN Client software on my laptop and it works fine (IP check shows that I’m in my home place).

But the problem that I can’t access the shared drive on my home PC (\, which is connected via WiFi to the Mango router (LAN).
At the same time, I can ping that PC: Reply from bytes=32 time=93ms TTL=127

Also, I can ping the Mango router itself in both WireGuard and LAN networks.
Reply from bytes=32 time=101ms TTL=64
Reply from bytes=32 time=103ms TTL=64

Obviously the “Allow Access Local Network” option is enabled in the WireGuard Server settings.
Ports 80 & 22 are open in the router’s firewall, so I remotely can access its Web interface and connect via WinSCP.

But what is not working is the shared folder access.
Will be glad to hear any bright ideas of what I’m missing.

The Windows firewall (or Norton or other antivirus firewall) may be blocking access from a different client subnet.

I do not work for and I do not have formal association with GL.iNet


Thanks for your advice, wcs2228!

I’ve added IP exception under Control Panel > System and Security > Windows Firewall > Advanced Settingsand select theInbound Rules` → “File and Printer Sharing (SMB-In)” → Scope → Remote IP Addresses. (Remote PC)

Now can I access the shaped folder on the remote PC, but only via IP [\].
If I type the PC hostname [\matebook] it doesn’t work. I can’t see remote PC in the ‘Network’ either…
Any thoughts how this can be fixed? There’s probably something to do with DNS?!

Also, when I access the PC via IP, the credentials window pops up, but I can type anything ‘bla-bla’ and it still logs in.
I have shared access to ‘everyone’ with no password. The credentials were never required when access the folder from LAN.

NetBIOS names like “matebook” do not traverse subnets. For only 1 client PC and 1 file server PC, the easiest method is to add an entry to the C:\Windows\System32\drivers\etc\hosts file on the client PC, to map the name to the IP address: matebook

When you first enter the credentials, you can enable to save them in WIndows, so you do not have to enter them again.

I think the credentials popup are due to the Public file sharing settings when you access from another subnet. At home, your connection probably uses the Private file sharing settings.


wcs2228, thanks for another valuable advise! I can now access the remote PC by it’s Host name “Matebook”.

1 Like