Losing contact with router

I purchased a GL-AR750S a few weeks ago. I am using it with a ZTE Velocity (MF923) ATT hotspot. The router keeps losing contact with the hotspot. The router is only about 20 feet away from the hotspot. Any other devices connected to the hotspot never lose contact with the hotspot. Any suggestions?

Is AR750S connecting to MF923 via 2.4G or 5G wifi?

Pls also report your firmware version of AR750s. In UI, click “upgrade” and you will find the version number.

When losing connections, pls ssh to the router and get the logs via “logread”

The firmware is 3.001. I have no idea what ‘ssh to the router’ is. Could you please explain. The router just lost connection AGAIN. I will definitely post the logs if you will explain how I can get them.

Just connect it to the Internet, better with a cable. The in the UI click Upgrade menu. You will find new firmware and upgrade the firmware. Do not keep settings.

Check out the docs here Upgrade - GL.iNet Docs

If you will read my reply, you will see that I posted the firmware version. It’s how to get the logs that I don’t understand how to do.

Are you saying that there is a new firmware?

https://dl.gl-inet.com/firmware/ar750s/

I personally use a “testing” version on the GL-AR750S I travel with. For most users, the “plain” version, named something like openwrt-ar750s-3.026-0729.tar is a reasonable one to flash through the GUI’s upgrade feature to get the latest updates available.

While there is always the possibility of a problem with “testing” versions, I have not run into any. Keeping the “last known good” version on a USB stick or your computer helps by having a local version you can flash back to, in the unlikely case something “goes wrong” and you can’t reach the Internet.

I have installed the latest firmware version 3.025. We’ll see if that helps.

I updated the firmware to the latest version, 3.025.

Would you please give me instructions on using the SSH command to get the logs?

We have good docs here

1 Like

@crawford69

Not sure what your circumstances are but have you considered USB tethering (Option 3) the MF923 to the AR750 instead of hot spotting to it? I have similar MiFi units and tether them to the AR750s and WiFi connect to the my AR750s .

You could then either leave all the other devices connected to the MiFi and connect to the AR750S or you could actually connect all devices to the AR750S and turn off WiFi on the MF923.

Might not be possible for you to do but if it is, you’ll get a much better/robust solution :slight_smile:

Thanks. I’ll definitely consider this.

Thank you so much to everyone for your input. Updating the firmware seems to have taken care of the problem.