Mango can't find channel 13 wifis on repeating mode

I even tried this based on the other thread. Thanks

uci set wireless.mt7628.country=‘JP’
uci set wireless.mt7628.region=‘5’
uci set wireless.mt7628.channel=‘13’
uci commit wireless
wifi

Do you use 4.x firmware?

Info on what I did

For those that want to SSH in to the router to enter the commands above

---- For windows - Go into putty:
hostname: 192.168.8.1 (or another)
then click open

terminal opens
type in root for login name, then admin pw (you can right click to paste pw)
then each of the 5 commands above. Router should restart and be able to use that channel.

In which country are you currently?

Hostname GL-MT300N-V2
Model GL-MT300N-V2
Architecture MediaTek MT7628AN ver:1 eco:2
Firmware Version OpenWrt 19.07.8 r11364-ef56c85848 / LuCI openwrt-19.07 branch git-21.189.23240-7b931da
Kernel Version 4.14.241

This is what I am running. Sorry for the late reply was trying to figure out where to find this info

UAE but I have mostly American(US) devices

The country code should be the same on all devices and should contain the country the devices are in.

My iPad and Mac, phones, tablet, and windows laptops are US items. My hotspot is local which sometimes broadcasts on channel 12/13 which I then use to connect to the mango as a VPN client.

I guess my biggest issue is the hotspot doesn’t allow me to choose the channel. Hence the mango also from the US doesn’t repeat the 12/13 channels. Most of my devices don’t see the mango hotspot either when I did get it to repeat the 12/13 channel.

Thx