MDIO BUSY error in uboot


We are prototyping a board based on the Domino Core, and are seeing errors very similar to those reported here:

i.e., many repeating lines of:

ag7240_mii_setup: MDC check failed

While the device seems to time out on this after about 10 or 20 seconds and boot, the ethernet interfaces fail to operate. We have this problem on both of our prototype boards, suggesting that we might have messed up the hardware in some way, although I haven’t got a clue where, as the ethernet traces simply feed directly to the RJ45 jacks with integrated magnetics. Schematics and other information on our prototype boards can be found at:

Has anyone seen (and hopefully solved) such a problem before?

Note that these units are still running the original factory supplied operating system.



Hi Paul, we replied your email. Hope this has been solved.


Confirming that the device does boot, even though we see these errors.




I’m trying to use my Domino with the dual ethernet block, but unfortunately I get the same error in the uboot and my Domino boots, but I don’t see the ethernet interfaces.


Would you mind helping.


Generally the errors doesn’t matter in uboot.

When you see “don’t see the ethernet interfaces” what do you mean? In uboot or firmware? What is the detailed problem?