Microuter N300 will not update to 3.100

I have a new Microuter N300 that reports as a GL-MT300N-V4-2c2 running firmware code 3.025, compiled: 2019-07-09 19:31:22. I am trying to update it to 3.100 using the file:

 openwrt-n300-3.100-1217.bin

From: https://dl.gl-inet.com/firmware/n300/testing/

Using the Local Upgrade WEB page. After I upload the file it shows:

MD5 0e3e95a263239d5908bf49493d1641ca
Verification Result Pass

I then turn off “keep settings”, and click “install”

After watching the update bar go across the screen for a couple minutes, it says: “Router Connection Lost”. If I power cycle the router, it will let me back into the admin screen, using the password I set, and the router shows it is still running firmware 3.025. Is there some trick to upgrading this router?

Update your firmware following this guide:

https://docs.gl-inet.com/en/3/troubleshooting/debrick/

It should fix it for future updates using the normal way.

Thank you for the information, but the Microuter N300 is not listed in this guide. There is only a single LED on this device, and I don’t know if I look for 3, 4, 5, 6 or some other number of flashes before releasing the reset button. Any help is appreciated.

The N300 is actually called GL-MT300Nv4, so it would be just the same procedure as the GL-MT300N-V2 which is 5 blinks. Give that a try and see. There is no way to damage anything if you do it wrong here.

It worked for me with 5 blinks. There is only 1 LED, so it changes in intensity. As there is only 1 Ethernet port, after the router loads the code, you have to connect via WIFI. It would be very nice if someone updated the debrick guide to cover all current shipping products.

Good news is I was able to connect to the n300 with the new 3.100 firmware, and it let me set a password. Bad news is it then goes to the page:

192.168.8.1/#/internet

And all I get is a spinning circle, with no graphics. Waited several minutes, and still nothing but a spinning circle. I have tried Chrome, Firefox, IE, and Edge, and I have tried Chrome in incognito mode, and rebooting the router several times, all with the same spinning circle results. I tried manually entering the page:

 192.168.8.1/#/wlan 

and I see the same spinning circle.

I was able to get into the luci page, but I’m not inclined to set it up this way.

I loaded the 3.025 code from the GL iNET firmware WEB site, using the same debrick method, and the router is working again with the older code…

This router with the 3.100 test code is just not ready for use. Kind of disappointed as I purchased it to test the new 3.100 code, as I don’t want to break my other 3 GL iNet routes that I am using in production. I may send it back to Amazon.

@alzhao @hansome @lancer @luochongjun

Hi, It should be a compatibility issue. It will be fixed later. Thanks.

I have a microuter N300. I am curious that is it possible to flash it with mango firmware? I think that using latest openwrt would be great. Thanks in advance.

Same issue here
Any plan to solve this problem?

It is 3.102 firmware now. What is the problem now? still cannot upgrade?

You cannot flash MT300N-V2 firmware on N300. It may work, but you need to configure the WAN port by yourself and it could be difficult.

It failed to upgrade to 3.102 from 3.025 by Local upgrade
I used filename openwrt-n300-3.102.bin