MiFi v2.27 no 3G, bricked by v2.271

I have a MiFi that when upgraded to v2.27, completely lost access to the cellular data network. I noticed it could see the modem, but trying new settings in the GUI never seem to stick, and nothing done in LuCI helped either.

I have also attempted without success:
Downgrading without saving settings.
Swapping SIM cards.
Swapping physical modems.

I tried to upgrade to v2.271, but after upload and hash verification the Reboot button did not seem to work. I waited 5 minutes before forcing a power cycle. Now it seems to be bricked: power LED is on, but the only other activity is occasional blinks from the 3G LED.

Is there anything else I could try, or is this thing hosed?

are you using a mifi with battery? Can you connect your charger to make sure it has enough power. Also take it to where there is good signal to check.

It does get signal, the GUI said it was getting signal. It was working fine last month before the update actually

@doujinflip Download v2.271 here, and upgrade again manually. Guide Debricked.

@kyson-lok Thanks for the unbrick instructions, I was able to reimage the MiFi

However, the original problem still remains: The cell modem still cannot access the data network. I know that the device is not blacklisted, and the APN settings are correct. Even reimaging to previous versions via uboot doesn’t seem to help

Maybe you can just reset the firmware then start over.

Then use the auto config settings of the UI to setup the modem.

I’ve tried that, multiple times. Even a full uboot reimage doesn’t get the modem to translate cell signal into mobile data

Ok, turns out I was inserting the SIM backwards :expressionless: Silly me. Everything seems to be working fine now, thanks for this learning experience!