MiFi with Ericsson F5521gw /dev/ttyACM* modem and glweb interface settings

Dear community,

I just received my GL-MiFi and it works perfectly. I ordered it without minipcie module, because I already had an Ericsson F5521gw at home.
I installed the module, booted up fine. Upgraded firmware to v2.22.

The Ericsson F5521gw MiniPCIe module (HP model, hs2340 HSPA+ MobileBroadband) was detected fine, but, it was not possible to create a connection through the glweb interface. Switched to advanced settings (LuCI), added the new interface there as UMTS/GPRS/EV-DO with modem device selected as /dev/ttyACM0, filled in my APN and it started working immediately. I was even able to set up LED configuration to show connected state properly on the box.

Going back to GL-MiFi’s own glweb interface, the “Internet status” is empty (says Cable not connected).

If I go to New connection > 3G the page says “Please plug in your modem”. But the modem is plugged in and it is working as I am accessing this forum through it right now. I also upgraded the system to testing firmware 2.24, still the same.

What can I do to make glweb interface also to recognize Ericsson F5521gw / HP hs2340 HSPA+ MobileBroadband modem?

Here’s lsusb info:

Bus 001 Device 004: ID 03f0:3a1d Hewlett-Packard 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            2 Communications
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x03f0 Hewlett-Packard
  idProduct          0x3a1d 
  bcdDevice            0.00
  iManufacturer           1 HP
  iProduct                2 HP hs2340 HSPA+ MobileBroadband

Thanks in advance!




OK, what I found so far is that this modem appears as /dev/ttyACM0 /dev/ttyACM1 /dev/ttyACM2 on the system. I just created symlinks of these to the old-style /dev/ttyUSB0 /dev/ttyUSB1 and /dev/ttyUSB2 and glweb interface recognized it!

Here’s a temporary fix to survive reboot:

Create a file called /etc/init.d/fixericsson with the following content:


for i in 0 1 2
if [ -e /dev/ttyACM$i ]; then
if [ ! -h /dev/ttyUSB$i ]; then
ln -s /dev/ttyACM$i /dev/ttyUSB$i
logger -t fixericsson Symlink from /dev/ttyACM$i to /dev/ttyUSB$i created
logger -t fixericsson Cannot create symlink because /dev/ttyUSB$i already exists!
logger -t fixericsson Theres no ttyACM$i device present, no need to symlink

symlink it so it can start properly at boot:

ln -s /etc/init.d/fixericsson /etc/rc.d/S21fixericsson
Reboot, after this you can set up a normal 3G WAN connection on the glweb interface, it automatically reconnects at each reboot, works as intended.

Would be nice though if glweb interface would recognise /dev/ttyACM* interfaces automatically.


thanks for reporting. Will fix this later.

Not fixed in 2.25 :frowning:

But, my script above still works as a workaround.

really? I think I added to check ttyACM* in the new firmware.

Well, in the glweb interface, the dropdown box still only shows the ttyUSB* options as selectable (which in my case are just symlinks to ttyACM*). It should show both…