Mobile version has issues for me

Hello there,

When I loaded the web interface on my pocco x3 nfc phone I noticed this on my brave browser:

The button on the bottom is almost not reachable.

It would be nice to fix this :+1:

I have the same issue with the VPN Dashboard when trying to select a new client when on my tablet. I have to rotate it back to portrait to be able to get to the “Apply” button.


I have the same issue with my iPhone XS. It looks like the pop ups are not scrollable to the bottom.

You have to hold the phone in landscape mode to see the full page.

So yea the router web page needs optimisation for mobile browser.

1 Like

The new Firmware (Beta8) has been optimized for mobile.
Please try to upgrade the firmware.
GL.iNet download center (


For wifi for 2.4 ghz I still cannot see the button once I have updated 5ghz.

Have you tried scrolling the page by dragging?

I tried to install brave browser on my iPhone, I can drag the page to the bottom.
Is the page scrollable on other browsers on your phone?

Ah I see why it doesn’t work:

If you click on modify for 5ghz and then scroll down then the bottom button is behind the scrollbar.

If I don’t click the modify button I can scroll further.

I have tested the 4.0 beta 8 UI on various browsers in mobile/desktop mode on iOS and Android, below is what I found so far:

Has issues:

  1. Chrome on iOS in mobile mode → after log on to the main screen, the top hamburger menu button line is almost covered and can’t be reached, however after switching to desktop mode then switching back to mobile mode, the top hamburger menu shows, however(again) after you log out then login again, the situation happens again in previous description (loop)

  1. Edge browser on Android: most long pages have the issue of bottom part been cut(can’t see or not seen completely)

No issues(workable) browser/platform:


  • DuckDuckGo / Firefox / Safari on iOS: normally render 4.0 beta 8 UI in mobile and desktop mode.
    ( DuckDuckGo renders perfectly in mobile and desktop mode)


  • DuckDuckGo: perfectly render 4.0 beta UI in mobile and desktop mode
  • Chrome / Firefox: normally render 4.0 beta 8 UI in mobile and desktop mode, however the bottom line " Copyright © 2022 GL.iNet. All Rights Reserved" part can’t be seen in mobile mode. (picky)

~~ Perfectly render: even the most subtle part is rendered
~~ Normally render: the functional button and information can been seen and is workable, however some subtle part render is not completed.
~~ Testing phones:

  • Google Pixel 4 XL (Android 12 QPR3 beta 3)
  • iPhone 11 (iOS 15.5)
1 Like

BTW, same thing (can’t scroll popup to get to the “Cancel/Apply” buttons, unless I rotate my tablet to Portrait) is happening with the “Ethernet Settings” (Protocol) pop up, so I’m guessing this is a general bug with non-scrollable popups. This is the latest (16 May) Beta, BTW.

Thanks. We will find a way to solve the adaptation problem of the Chrome browser on iOS and the Edge browser on Android.

1 Like

What model is your tablet? What browser are you using?
Some browsers cover the bottom or top of the page, we are trying to fix this.

Chrome on Android, Chrome on Chromebook; both up to latest versions of OS and Browser.