Modi constantly rebooting

I’ve had a modi travel router since they were first released. It’s been great!

Due to COVID I’ve not done much traveling over the last year so it’s been sitting in a drawer.

I’ve recently wanted to use it and I’m finding that it will boot up and after 5 minutes or so it will shutdown.

The only change I can think of is updating it to the latest firmware and wondering if there’s some strange interaction between the newest firmware and some thermal issue. But I figure if that was the problem everyone would be suffering the same issue.

Can anyone offer some guidance for troubleshooting tips to try?

I have attempted to backup the router both by the “normal” backup method and dumping each of the partitions. However, I’ve not been able to backup the final (biggest) partition as it shuts down before the dump completes.

I was doing the backup and then going to try a reinstall. Which raises another question: what’s the best way to perform such a re-install - especially when the system is unstable and may fail partway through?


Can you use uboot to reflash the router Debrick via Uboot - GL.iNet Docs

What does the screen show when it shutdown?

Thanks for that link.

I followed those instructions and reflashed via uboot. I chose to use the 105 image file instead of the latest 203-0701 image file - to see if there was some bug that crept into the latest firmware.

However, it seems to be exhibiting the same behaviour. I suspect the issue is heat related as the first time I power it on, it stays on for a period of time, but after the second or third restart, it won’t even complete booting before it shuts down.

A few other points:

  1. To answer the “what’s shown” question. The display shows the shutdown message and it takes a few seconds for this to complete. So it seems to be doing a clean shutdown. That is, it doesn’t just power off. This suggests something is triggering the shutdown (via software?) rather than a pure hardware heat issue.

  2. It seemed to remain up when at the uboot web page. I think I’ll redo putting it into uboot mode (where the display prompt to open a web page to, and leave it over night to see what happens. If it’s still at that in the morning, that would suggest the issue is software related.

I’ll update tomorrow.

  1. I currently don’t have a SIM or SD card installed and I have it plugged into the Ethernet adapter and that is also plugged into a USB-C charger.

One final comment, the page I downloaded the image files from:

Could the list.txt file include the hash of the img files not just the tar files.

Thanks for the assistance!

A further update.

I left the Mudi booted into uboot recovery overnight and it was still up in the morning.

This would suggest there’s some strange software issue with the openwrt based firmware that causing the shutdown.

Maybe it is just overheat and shut down.

Can you try to reset the MCU to see if it fix the issue?
Open the SIM card cover, there is a big hole and a small hole. Use a pin to press the button inside the small hole. The router will immediately reset and reboot.

If it does not work, pls come back or talk to our customer service to get a replacement.


I think that’s what I’ve already done? Isn’t pressing that button inside the small hole (labelled “reset”) the way to get it to uboot recovery prompt?

I’ve left it sitting at the u-boot recovery all day. Which suggests it’s not a pure hardware heat related issue. But I tried to install an image (this time I tried using the 3.100 image) and it installed successfully, then started booting, but just after the GLinet logo appeared, it reported it was shutting down.

Is there anything else I should try? Or what’s the process for getting a replacement?


Just pm me your purchase channel and order number and I will forward.


I’ve been scouring the forum site to figure out how to send you a pm.

I bought it through the original Kickstarter.

If you can point me at the instructions for sending a pm, I’ll send through any other info you need.

How about this, you can send email to cs at and describe the problem.

Be sure to Quote the url of this thread。

Thanks alzhao.

Email sent. :slightly_smiling_face: