MT-1300 (Beryl) repeater Mode Never Connecting to Wifi

I’ve now tried to connect to two different (motel) networks in repeater mode with no luck. It’ll show the SSIDs and let me try to join them, but after that, nothing actually happens. Usually, the wifi connection I have to the router will drop and reconnect like 20 seconds later, then on the status page it just shows repeater mode as disabled. Going back to the saved list and clicking “join” causes the same behavior to happen again.

Tethering my phones wifi to the router works fine, but that’s far from ideal and not really why I bought it.

I did get it to work once by repeating my phone’s shared wifi, but not on any other networks.

I’ve seen some people mention similar issues, but with all the good reviews and lack of talk about this, I don’t know what to think (Maybe fake reviews?). The second motel I tried it with I doubt has any sort of sophisticated system blocking routers.

The only other thing I tried was fiddling with the country code settings in /etc/wireless that are oddly set to CN, but that didn’t seem to make a difference. I also made sure to upgrade to the latest firmware (same issue after upgrading).

Emailed support, but they have not gotten back to me at all.

Here are my logs around the time it happens, but I don’t see anything particularly informative as to what is going on myself: Mon Jun 21 00:49:34 2021 daemon.notice procd: /etc/rc.d/S99gl_route_policy: uci: -

Checked the log. Seems the router is connected but cannot get IP, so dropped.

Got similar cases, still finding a way to solve

May send a test firmware in a few days