MT-300A max usb devices?


#1

Hi, i own 2 of MT300A devices. I just wanted to setup one as NAS.

Configuration is: MT300a (FW 2.264 or 3 beta) with connected 4 BAY USB housing (FANTEC)

In Windows Explorer only 2 disks are visible of 4 installed. Their Filesystem is NTFS or exFat (both addons installed and both filesystems are visible in Explorer but only 2 of 4 disks.

Can someone help?


#2

what is the size of the 4 disks?

Is all exFat system not supported?


#3

Tank you for answering!

Disk 1 is 5TB exfat - detected
Disk 2 is 4TB exfat - Not detected
Disk 3 is 2TB Ntfs - Not detected
Disk 4 is 1TB Ntfs - detected


#4

what is the volume label?

It should not have special characters inside.


#5

1TB, 4TB and so on. No spaces. In windows Explorer they are named (the visibles) 1TB and Basic Data Partition for the 5TB exfat Disk.


#6

Can you ssh to the router and check?

To list all the devices

ls /dev/

To list the config of smaba

cat /etc/config/samba

#7

root@GL-MT300A:~# ls /dev/
bus mtd0ro mtd7 null sdd ttyS3
console mtd1 mtd7ro port sdd1 ttyS4
cpu_dma_latency mtd1ro mtdblock0 ppp shm ttyS5
full mtd2 mtdblock1 ptmx tty ttyS6
fuse mtd2ro mtdblock2 pts ttyS0 ttyS7
kmsg mtd3 mtdblock3 random ttyS1 ttyS8
log mtd3ro mtdblock4 sda ttyS10 ttyS9
mem mtd4 mtdblock5 sda1 ttyS11 urandom
memory_bandwidth mtd4ro mtdblock6 sda2 ttyS12 watchdog
misc mtd5 mtdblock7 sdb ttyS13 watchdog0
mmcblk0 mtd5ro net sdb1 ttyS14 zero
mmcblk0p1 mtd6 network_latency sdc ttyS15
mtd0 mtd6ro network_throughput sdc1 ttyS2

config samba
option workgroup ‘WORKGROUP’
option homes ‘1’
option name ‘GL-MT300A’
option description ‘GL-MT300A-xxx’

config sambashare <<micro SD internal
option name ‘CN32GB’
option path ‘/mnt/CN32GB’
option read_only ‘no’
option guest_ok ‘yes’

config sambashare
option name ‘1TB’ <<< drive 1 NTFS visible in Windows
option path ‘/mnt/1TB’
option read_only ‘yes’
option guest_ok ‘yes’

config sambashare
option name ‘Basic data partition’ <<< drive 2 exFAT visible in Windows
option path ‘/mnt/Basic data partition’
option read_only ‘yes’
option guest_ok ‘yes’


#8

Your disk registered 4 devices
sda1 sda2 sdb1 sdc1

Seems not all of them are mounted.
Can you check again using the following command

mount

Maybe you need to try mount manually.


#9

partly solved:
Checked the drives with mini tool partition wizard. 2 of 4 are GPT set. - one of those (5TB) is found by MT300A but has no content in explorer.
The other 2 drived are MBR now (1 and 2 TB) I converted the 2TB to MBR.
The 4th drive is 4TB GPT exFAT - still not mounted. Was unable to change to MBR because of size.
Issue while trying to mount: The device ‘/dev/sda2’ doesn’t seem to have a valid NTFS.

So far, many thanks to you alzhao! Its nice to see a manufacturer that delivers that support today - again: Thumbs up!


#10

Thanks for let me know.


#11

Only 1tb and 2tb NTFS drives with MBR are accepted reliable on MT300A :expressionless: i’m Bit sad About this…