MT-300N v2 won't reconnect to WiFi as Repeater


#1

Very disappointed with my MT300N. I have two wireless networks (tethering hotspots) at home and I want the MT to connect to whatever is up and running at the moment. The router won’t connect automatically to the saved networks. Instead, I have to do the gymnastics of opening up the admin page and forcing it to Join one of the saved networks. If I stop the hotspot and turn on the other one, it won’t reconnect.

The router hangs at random and needs constant reboots. WiFi range is hilariously bad too.

And lastly, if I connect it to a phone via USB tethering, the software is not smart enough to prioritize that source of Internet, over the Radio connection. The software does not seem support such kind of prioritization, at least in the UI and I’m not masochistic enough to go and learn Linux just for that.

Overall, a very disappointing experience.


#2

Could you please try to upgrade to the latest testing firmware? https://dl.gl-inet.com/firmware/mt300n-v2/testing/

It seems that it is a bug in old firmware, which won’t connect automatically.


#3

Well, I am running the latest stable release at the moment, but I may give this a try, thanks. Since it’s a beta, anything to look out for?


#4

Yup, it is a beta, you can try it. Any feedback is welcome.


#5

That beta version makes day and night difference. Works exactly as I’d expect, great improvement. I’m not downgrading.

A few comments:

  • when both - USB tethering and Saved WiFi are available, USB tethering should be prioritized (faster)
  • I’d love to have the ‘timeout’ interval between losing one saved WiFi and reconnecting to another to be much shorter.
  • I’ve noticed something weird: let’s say the router is up and running but no Saved WiFi is available. A client is connected to the router, of course no internet available. I turn on the hotspot (the saved network for the router). I’ve noticed that I have to reconnect the client to the router, to get internet. I wasn’t even able to open the router page until I reconnected to the router.

But overall, a great improvement, thanks.