MT-300N: wireless doesn't auto start?

Hello,

My MT-300N doesn’t auto start the wireless module after it’s been unplugged for a while. I have to connect via the LAN port and turn it back. Is there a reason why, and can I turn it on automatically?

Did you press the reset button which may disable/enable the wifi?

Did you connect to your main router as a repeater?

I also have this issue, on both 2.17 and openvpn test firmware, but I have two mT300N’s and the other one does not have this problem.

I’m using it as a repeater.

I am not sure what is the exact problem because I don’t know your use scenario.

When used as repeater, if the router cannot connect to the main router, its own signal cannot be up either. This is a well known problem of signal radio routers.

I am using my MT-300N as a repeater.

My use case is for travel: when I’m on the road, I’d like to use this as a repeater for all my devices to log into hotel Wifi. Having to log into the MT-300N via LAN means I have to carry around the ethernet cable and adapter.

you can modify /etc/rc.button/reset, use the reset key to turn on/off the repeater.

When you press the Reset button, now it will execute /usr/bin/wifionoff

change its content something like this:


#!/bin/sh
device=$(uci -q get wireless.@wifi-device[0].disabled)
sta=$(uci -q get wireless.sta.disabled)
if [ "$device" = "1" -o "$ap" = "1" ]; then
uci set wireless.sta.disabled=0
else
uci set wireless.sta.disabled=1
fi

uci commit wireless

wifi