MT2500 Wireguard connection using wrong route

I have two connections on my MT2500, a fast WAN connection and a slower TETHERING connection is the fast WAN is the slow TETHERING (set as FAILOVER)

I noticed on the VPN it would only ever connect at a slow speed

When I run ip route show - it shows the VPN connection tied to the slow eth2 route

How do I fix this, and get the VPN connecting through eth0? dev wgclient scope link
default via dev eth0 proto static src metric 10
default via dev eth2 proto static metric 30
xx.xx.xx.xx/10 dev tailscale0 scope link dev wgclient scope link dev eth0 proto static scope link metric 10 dev eth2 proto static scope link metric 30 dev br-lan proto kernel scope link src
xx.xx.xx.xx via dev eth2 proto static metric 30

Don’t forget to disconnect & reconnect your WG connection when you change ‘priorities’ under GL GUI → Network → Multi-WAN → Interface Priority. That seems to be ‘the trick’ to it for force the changes.

Related but your case seems to be the exact opposite of the following issue:

That was my original issue.
I have now swapped my interfaces so the faster is WAN and the slower is tethering as I get a faster throughput on the built in port to the USB-Ethernet adaptor.
I’ve restarted the VPN a few times to try different servers as I thought it was just slow VPN access that you get sometimes.

This seems to work - is it a bad thing to do?

In advanced settings I have put the VPN Client Virtual IP address as the Source Address.

I don’t have any static IPv4 routes by default in LuCI on my single WAN Flint so I can’t really comment.

(I mentioned that bug report thread as GL responded that mwan3 & iptables should be updating automatically. I wasn’t aware if you’ve read the new info.)

What’s the device assigned to I’m not sure I have much advice to give on the ‘best practice’ here given the precieved reports & documented details of the aforementioned trouble. is my WAN - faster connection

So if the WAN via Ethernet is now your preferred connection instead of the thethered device, I’d just back up your VPN profile, reset the MT2500 back to factory defaults, then add your VPN profile again. We know the default metric is going to prefer WAN/Ethernet ‘out of the box.’

Ok thanks. That’s a job for another day!

I reset today and this is now all working as expected. Thanks.

EDIT: After a reboot VPN is back to using failover connection - odd one