I am having trouble with a seemingly simple task using a mango. Wired wan connects to my network.

Wired lan, I configured to match my Mac tops ip. Subnet and mask. But wan and lan do not see each other how can I correct this. I’m trying to test a firewall issue an d the Mac top has a forced or static network config. I set my lan ip one tick off the Mac tops. I also tried to force the Mac and ip in the table with no success.

Please advise. Thankyou

Too few text and too much information.

Can you give details with figures and screenshot etc?

Let’s try this again on a simpler level.
I have a mactop that has a static ip that I cant change. .

I want to plug this into the lan connection of the mt300v2.

I want the wan to be dhcp and pick up my existing network connection.

I believe I want them to bridge together so the mactop can reach the internet.

What seemed so simple is beginning to become complicated.

Please advise, thank you

If that is a static, public IP, you will never be able to reach the Internet without NAT. So it has to be routed, not bridged. If you don’t NAT, return packets will go to its rightful home.

You don’t need the router to be a DHCP client on its LAN. You to need it in the same subnet.

Can you explain how you have a “mactop” that has a fixed, public IP on a large subnet that you can’t change, yet you somehow expect to change its routing and potentially other services? What do you plan on doing for IPv6, which is likely locked down as well?

Edit: Your description of your use case is still not clear at all.

Retaining the ip and subnet are critical to apple, if I could change it without upsetting the apple cart it would be so much easier.

Basically I’m trying to mirror my corporate network without the firewall. I have an issue with apple and trying to take the firewall out of the equation.

I was told that this device would allow me to retain the ip and I can change the subnet in openwrt.

Is this do able?

How are you going to connect the GL-MT300Nv2 (yes?) to the Internet?

Is the laptop statically configured, or it is a DHCP client of your corporate network?

(Edit: Probably doable, but need more information.)

Mactop has a static ip and subnet

Connected to via the LAN connection on the GL-Mt300n-v2.

My home network internet wired in to WAN, with DHCP on the GL-mt300n-v2.

On the Gl-mt300… I configured the lan to be and narrowed the start and stop to 30 and 35

under advanced, openwrt I changed the subnet to but the mactop is not seeing the internet so right out of the gate my config could be in error.

I also tried tying the mactop mac addr and ip with no success.

What is the gateway address for the Mac? That needs to be the (a) LAN address of your router.

What about the Mac’s DNS resolvers? They either need to be repointed to the router, or the router needs to supply DNS on the same addresses (assuming that the Mac is trying to use your private, corporate DNS servers).

yes using openwrt I provided all that detail.

There are still several detail missing. As an outline, you will need to replicate all the IP addresses and services that your “mactop” needs to operate. This includes at least:

  • LAN on the same subnet with the same net mask
  • LAN on the same IP as the mactop is expecting for its default route
  • LAN supplying DNS on at least the same IP as the first resolver configured in the mactop

If “mactop” means a device running current macOS, then these can be seen in the Network pane of the System Preferences app. Click the “Advanced” button. Under the TCP/IP tab, look at “Router”. Under the DNS tab look at the list under “DNS Servers”

yes mactop meaning osX Catalina

done* LAN on the same subnet with the same net mask

  • LAN on the same IP as the mactop is expecting for its default route
    ok maybe this is where I am stumbling. Under “more settings” (not under openwrt) I set the router ip as and start at 30 and stop at 35. As I understand it this is the ip address for the router. Start and stop is for the ip address window on the lan. I tried to bind the mactops mac address and ip address, with little success.

In openwrt “network/interfaces/lan” edit I added all the mactop specific details. However, I was a little confused (ok lot confused) on DHCP server section and elected to “ignore interface”. Was that the right option after all I was looking for a static solution?

done* LAN supplying DNS on at least the same IP as the first resolver configured in the mactop

Thanks and appreciate your expertise, will check the network pane this evening.

I tabled the effort, either the device is still a bit buggy or I need better documentation, but I could never get it to behave, or connect. Even using a windows laptop I could not get an internet connection from Lan to Wan.

thanks for your time and effort.

When you come back to it…

If all you are trying to connect is the “mactop” and it has a static address, you do not need DHCP running on the router. If you need other hosts at the same time that need DHCP, then you would need to configure DHCP somewhere in proper subnet. with a mask of looks very strange to me. 124 = 0b01111100 – note the leading zero in that byte.

If it were, then the CIDR would be and it might be that the default router is on (it is not a requirement at all, and is a valid IP address).

One of many CIDR calculators is at

Thank you, and thanks for working the boards, your expertise is appreciated!