Mt3000 beta / snapshot firmware

4.1.3 snapshot firmware dated 20230107 spotted, anyone tried?

Well that’s interesting. WIthout notes it is hard to tell what from what. I’m working on the 4.2.0 snapshot of 1/6, and it seems to have resolved most of the issues I had with the 4.2.0 beta.

It would be nice to know what we should be testing.

Especially with daily snapshots coming out. Some sort of daily changelog would be helpful.

1 Like

i wouldn’t touch the snapshots as they are unstable - just wait for the betas. (which is a little more stable lol)

1 Like

Decided to flash to 4.2.0 snapshot conplied 1-9-23

4.2.0 beta 2 had too many issues for my unit. Wouldnrefuse to scan and connect to 5ghz networks. Would detect mixed networks but refuse to connect to 5ghz.

Will test the latest snapshot and see if this resolves the issues.

I’m on the 1-8 snapshot and it actually seems to be performing fairly well.


1-9 snapshot was a dud, had to revert to 4.2.0 beta 2 via debrick method. But funny enough 5gHz connectivity issues seems to be not present for the past 2 hours.

Please explicate “dud”, since the 1/6 snapshot works better for me and some other testers.

I ran into a situation where wireless failed completely on 1-8 and 1-9 snaps. I did a custom infra build that seems to be working, but I haven’t gotten a chance to do a lot of testing today.

1-9 snapshot bricked the device, can you point me to where you I can download 1-6 snapshot from as its no longer available in the download center.

Would definitely love to hear how the performance is after the changes you made. I am still not able to go past 200mbps when using the MT3000 in wireless repeater mode connected to other WiFi6 routers. My AXT1800 in the same environment when tested gives me 330+mbps up/down.

Only the SDK4.2 snapshot fixes the repeater speed issue. Please wait for stable firmware in the next few days to test the wifi speed.

1 Like

Unfortunately I’m in a hotel for a few days and not in a place to really test full repeater speed. Pretty much anything will work when you’ve got 20mpbs to play with :).

My NAS will saturate a 1gbps ethernet link, wired. Wired to WiFi6 router, 5G connection to the MT3000, then 5G connection to a WiFi6 laptop, transferring a large file I get between 150-250mbps from the NAS to the laptop.

Wired to WiFi6 router, 5G connection to the Wfi6 laptop (skipping the MT3000), transferring a large file I get between 250 and 325mbps.

Right. And if I was home it would be easy, but for the next few days I’ve got a hotel room, a laptop and a phone with a 20mbps uplink. So some limits.