MT3000 - Unable to enter uboot web ui

I am unable to enter the uboot ui on any of the 4 MT3000s I have tried.
Usual settings, Linux laptop ethernet set to 192.168.1.2. Press and hold the reset button - plug in the power and wait until the led stops flashing. No response in Firefox at 192.168.1.1.

This works fine on any other model eg B1300, MT1300, MT300N-V2 etc.

Am I missing something?

Did you try this carefully?

Yes. Carefully. Including the led sequence in your link. No response to 192.168.1.1 in a browser.
No response pinging 192.168.1.1.

All other models I have tried (B1300, MT1300, MT300N-V2, AR300M-16) all work perfectly, following your link, with my Linux laptop configured in exactly the same way, with the exact same ethernet cable.

Cache…

test another browser

If you can’t ping it’s never an browser issue.

I tried on Windows a long time ago and it worked, on the same router (Beryl AX)

Indeed, although I did try Opera as well, to no avail.
Exactly the same procedure with the same Linux laptop (OpenSuse Tumbleweed), same ethernet cable, Firefox, and all the other models I listed previously - it works perfectly.

But it does not work on any of the MT3000s that I have. They have widely different serial numbers so it is not a manufacturing batch problem.

Further testing reveals:

  1. holding the reset pressed and plug in the power. Led flashes 6 times in blue then goes to solid white. On releasing the button, no pings returned from 192.168.1.1, but after a few seconds, rapid flashing and it boots up to what is on the flash.
  2. If the button is held instead of being released, after a few more seconds, rapid flashing begins and it boots in “failsafe” mode, ie the flash image with all changes removed.

My conclusion is that the uboot webui is not available, or at least not on 192.168.1.1.

I can reflash using sysupgrade or luci, but this is messy for a rollout of a number of units.

Is there a way of updating the uboot given that I cannot get into the existing uboot webui?

Why is it messy? It’s way easier to automate the SSH commands than the uboot ones.

Stupid question but do you use GL firmware all the time or did you flash plain OpenWrt before?

No, a custom OpenWrt. But I cannot get into the uboot even on a new unit otherwise untouched from the factory.

Because each unit would have to be booted in gl firmware, password set etc etc, then the custom image transferred, then sysupgraded. Takes maybe 5 minutes.
Compared with, open the box, connect the ethernet, power up into uboot and reflash - done in less than a minute.

I can use sysupgrade to go from gl firmware to openwrt and back to gl as many times as I like.
But I have never seen the uboot webui on an mt3000.

That’s the reason. The custom OpenWrt firmware will override uboot. That’s why the show warnings like this one:

So if you installed the factory OpenWrt image you have to go through the OpenWrt debricking method: [OpenWrt Wiki] Installing OpenWrt via TFTP

I doubt that you can get back to GL uboot without any further assistance by the @staff.

I’m not sure it is the full story because from memory, a new unit untouched from the factory will still not go into the uboot webui. I guess I will open a new one and try again!

I have always used the openwrt sysupgrade version as created by imagebuilder.

OpenWrt does not provide a factory image for the mt3000, so it cannot be that.

@alzhao Any idea why uboot does not work?

Hmm the handling seems correct especially the pressing before adding the power part, and there was only one cable in lan 1?

Could it be its only working on the first led flash indicator? :wink:

I suspect it to be some sort of timer canceling the u-boot function if its too long but i’m not sure.

Usually i dont wait to long on the indicator when i go into u-boot on other models.

Only the one cable from “lan” to the laptop, just as I would for any other model.

That is why I tried a continual press and found it booted the flash then did a “failsafe” aka “factory” reset.

I have tried pinging 192.168.1.1 while going through the process. With all other models, I get ping responses as soon as uboot is ready. But on mt3000, it does not happen.

1 Like

I just picked up one of these yesterday. It bricked while updating luci firmware… And now I can’t access the Uboot web ui either…

What firmware did you upgrade to?

https://firmware-selector.openwrt.org/?version=23.05.2&target=mediatek%2Ffilogic&id=glinet_gl-mt3000

Kernel or sysupgrade?

It might be possible that you destroyed uboot by flashing OpenWrt.
In that case you need to follow this instruction: [OpenWrt Wiki] Installing OpenWrt via TFTP

It was sysupgrade. Am I not supposed to flash and update WRT? I updated the Gl.net admin panel first to 4.5 or what ever it was and noticed the 3000 was running wrt 21.

Not really.

You can choose between two different operating systems: OpenWrt and GL OpenWrt (which is preinstalled).
If you choose OpenWrt, then you have to stay there - but it’s a different OS.

1 Like